Introduction

TeX Frequently Asked Questions

Brought to you by the UK TeX Users Group

Welcome to the WWW version of the UK TeX Users Group TeX Frequently Asked Questions list.

There were 136 matches. You can get all of them by pressing here.

The TeX FAQ is provided by the UK TeX Users Group (UKTUG-Enquiries@tex.ac.uk)
Comments, suggestions, or error reports may reported direct to the FAQ maintainer.
This is FAQ version 2.4.7a, last modified on 2000/07/07.


The Background

  • What is TeX?

  • How should I pronounce ``TeX''?
  • What is Metafont?
  • What is MetaPost?
  • How can I be sure it's really TeX?
  • Are TeX and friends Y2K compliant?
  • What is LaTeX?
  • How should I pronounce ``LaTeX(2e)''?
  • Should I use plain TeX or LaTeX?
  • What is CONTeXT?
  • What are the AMS packages (AMSTeX, etc.)?
  • What is Eplain?
  • What is Lollipop?
  • What is Texinfo?
  • If TeX is so good, how come it's free?
  • What is the future of TeX?
  • What are TUG and TUGboat?
  • Are there nationally-based user groups, too?
  • TUG Technical Working Groups


Documentation and Help

  • Books on TeX and its relations

  • Books on Type
  • Where to find this article
  • Where to get help
  • (La)TeX Tutorials
  • Metafont and MetaPost Tutorials
  • BibTeX Documentation
  • The PiCTeX manual
  • Finding (La)TeX macro packages
  • Finding files in the CTAN archives


Bits and pieces of TeX

  • What is a DVI file?

  • What is a driver?
  • What are PK files?
  • What are TFM files?
  • Virtual fonts
  • \special commands
  • Documented LaTeX sources (.dtx files)
  • What are the EC fonts?
  • What is TDS?


Acquiring the Software

  • Repositories of TeX material

  • What's the CTAN nonfree tree?
  • Contributing a file to the archives
  • Finding new fonts
  • TeX CDROMs


TeX Systems

  • (La)TeX for different machines

  • TeX-friendly editors and shells
  • Commercial TeX implementations


DVI Drivers and Previewers

  • DVI to PostScript conversion programs

  • DVI drivers for HP LaserJet
  • DVI previewers


Support Packages for TeX

  • Fig, a TeX-friendly drawing package

  • TeXCAD, a drawing package for LaTeX
  • Spelling checkers for work with TeX


Literate programming

  • What is Literate Programming?

  • WEB for C, FORTRAN, and other languages


Format conversions

  • Conversion between (La)TeX and others

  • Conversion from (La)TeX to plain ASCII
  • Conversion from SGML or HTML to TeX
  • (La)TeX conversion to HTML
  • Making hypertext documents from TeX
  • Making Acrobat documents from LaTeX
  • Using TeX to read SGML or XML directly


Metafont

  • Getting Metafont to do what you want

  • Which font files should be kept
  • Getting bitmaps from the archives


PostScript and TeX

  • Using PostScript fonts with TeX

  • Previewing files using PostScript fonts
  • TeX font metric files for PostScript fonts
  • Problems using PostScript fonts
  • Choice of scalable outline fonts
  • Including a PostScript figure in (La)TeX


Special sorts of typesetting

  • Drawing with TeX

  • Double-spaced documents in LaTeX
  • Formatting a thesis in LaTeX
  • Flowing text around figures in LaTeX
  • Alternative head- and footlines in LaTeX
  • Including a file in verbatim in LaTeX
  • Including line numbers in typeset output
  • Generating an index in (La)TeX
  • Typesetting URLs
  • Citing URLs with BibTeX
  • Using BibTeX with plain TeX
  • Typesetting music in TeX
  • Drawing Feynman diagrams in LaTeX


How do I do X in TeX or LaTeX

  • Proof environment

  • Symbols for the number sets
  • Roman theorems
  • Fancy enumeration lists
  • Unnumbered sections in the Table of Contents
  • Footnotes in tables
  • Style of section headings
  • Indent after section headings
  • Footnotes in LaTeX section headings
  • Changing the margins in LaTeX
  • Finding the width of a letter, word, or phrase
  • Changing the space between letters
  • Excluding blocks of text from the DVI file
  • Setting bold Greek letters in LaTeX
  • Defining a new log-like function in LaTeX
  • Typesetting all those TeX-related logos
  • 1-column abstract in 2-column document
  • Changing babel's ideas of words to use
  • Code listings in LaTeX


Macros for Particular Types of Documents

  • Setting papers for journals

  • A `report' from lots of `article's
  • Curriculum Vitae (Resumé)


Things are Going Wrong...

  • Weird hyphenation of words

  • (Merely) peculiar hyphenation
  • Accented words aren't hyphenated
  • Enlarging TeX
  • Moving tables and figures in LaTeX
  • \pagestyle{empty} on first page in LaTeX
  • Underlined text won't break
  • Odd behaviour of \rm, \bf, etc.
  • Old LaTeX font references such as \tenrm
  • Missing symbols
  • LaTeX gets cross-references wrong
  • \@ and @ in macro names
  • Where are the msx and msy fonts?
  • Where are the am fonts?
  • `String too long' in BibTeX


Why does it do that?

  • What's going on in my \include commands?

  • Why does it ignore paragraph parameters?
  • What's the reason for `protection'?
  • Why doesn't \verb work within...?
  • Case-changing oddities
  • Why are # signs doubled in macros?
  • Why does LaTeX split footnotes across pages?
  • Getting \marginpar on the right side
  • Why does PiCTeX run out of `\dimen's?
  • Why won't LaTeX `fixed' names stay changed?


Current TeX Projects

  • LaTeX2e (the `new' standard LaTeX)

  • The LaTeX3 project
  • The Omega project
  • The NTS project
  • The PDFTeX project


Perhaps There isn't an Answer

  • What to do if you find a bug


What is TeX?

TeX is a typesetting system written by Donald E. Knuth, who says in the Preface to his book on TeX (see TeX-related books) that it is ``intended for the creation of beautiful books -and especially for books that contain a lot of mathematics''.

Knuth developed a system of `literate programming' to write TeX, and he provides the literate (WEB) source of TeX free of charge, together with tools for processing the web source into something that can be compiled and something that can be printed; there's never any mystery about what TeX does. Furthermore, the WEB system provides mechanisms to port TeX to new operating systems and computers; in order that one may have some confidence in the ports, Knuth supplied a test by means of which one may judge the fidelity of a TeX system. TeX and its documents are therefore highly portable.

TeX is a macro processor, and offers its users a powerful programming capability. For this reason, TeX on its own is a pretty difficult beast to deal with, so Knuth provided a package of macros for use with TeX called plain TeX; plain TeX is effectively the minimum set of macros one can usefully employ with TeX, together with some demonstration versions of higher-level commands (the latter are better regarded as models than used as-is). When people say they're ``programming in TeX'', they usually mean they're programming in plain TeX.


How should I pronounce ``TeX''?

The `X' stands for the Greek letter Chi, and is pronounced by English-speakers either a bit like the `ch' in `loch' ([x] in the IPA) or like `k'. It definitely is not pronounced `ks'.


What is Metafont?

Metafont was written by Knuth as a companion to TeX; whereas TeX defines the layout of glyphs on a page, Metafont defines the shapes of the glyphs and the relations between them. Metafont details the sizes of glyphs, for TeX's benefit, and details the rasters used to represent the glyphs, for the benefit of programs that will produce printed output as post processes after a run of TeX.

Metafont's language for defining fonts permits the expression of several classes of things: first (of course), the simple geometry of the glyphs; second, the properties of the print engine for which the output is intended; and third, `meta'-information which can distinguish different design sizes of the same font, or the difference between two fonts that belong to the same (or related) families.

Knuth (and others) have designed a fair range of fonts using Metafont, but font design using Metafont is much more of a minority skill than is TeX macro-writing. The complete TeX-user nevertheless needs to be aware of Metafont, and to be able to run Metafont to generate personal copies of new fonts.


What is MetaPost?

The MetaPost system (by John Hobby) implements a picture-drawing language very much like that of Metafont except that it outputs Encapsulated PostScript files instead of run-length-encoded bitmaps. MetaPost is a powerful language for producing figures for documents to be printed on PostScript printers, either directly or embedded in (La)TeX documents. It includes facilities for directly integrating TeX text and mathematics with the graphics. The PostScript output is of such a simple form that MetaPost output files can be directly documents (Qref{Q-pdftex}). (Knuth tells us that he uses nothing else but MetaPost for diagrams in text that he is writing.)

Much of MetaPost's source code was copied from Metafont's sources with Knuth's permission.


How can I be sure it's really TeX?

TeX (and Metafont and MetaPost) are written in a `literate' programming language called Web which is designed to be portable across a wide range of computer systems. How, then, is a new version of TeX checked?

Of course, any sensible software implementor will have his own suite of tests to check that his software runs: those who port TeX and its friends to other platforms do indeed perform such tests.

Knuth, however, provides a `conformance test' for both TeX (trip) and Metafont (trap). He characterises these as `torture tests': they are designed not to check the obvious things that ordinary typeset documents, or font designs, will exercise, but rather to explore small alleyways off the main path through the code of TeX. They are, to the casual reader, pretty incomprehensible!

Once an implementation of TeX has passed its trip, or and implementation of Metafont has passed its trap, test it may reasonably be distributed as a working version.


Are TeX and friends Y2K compliant?

Crashing:

None of TeX, Metafont or MetaPost can themselves crash due to any change whatever in the date of any sort.

Timestamps:

As Knuth delivers the sources, a 2-digit year is stored as the creation time for format files and that value is printed in logfiles. These items should not be of general concern, since the only use of the date format file is to produce the log output, and the log file is designed for human readers only.

Knuth's distributed source does not designate the code, which generates this 2-digit date, as a valid area where implementations may differ. However, he announced in 1998 that implementators can alter this code without fear of being accused of non-compliance. Nearly all implementations that are being actively maintained had been modified to generate 4-digit years in the format file and the log, by the end of 1998.

The \year primitive:

Certification of a TeX implementation (see trip/trap testing) does not require that \year return a meaningful value (which means that TeX can, in principle, be implemented on platforms that don't make the value of the clock available to user programs). The TeXbook (see TeX-related books) defines \year as ``the current year of our Lord'', which is the only correct meaning for \year for those implementations which can supply a meaningful value, which is to say nearly all of them.

In short, TeX implementations should provide a value in \year giving the 4-digit year Anno Domini, or the value 1776 if the platform does not support a date function.

Note that if the system itself fails to deliver a correct date to TeX, then \year will of course return an incorrect value. TeX cannot be considered Y2K compliant, in this sense, on a system that is not itself Y2K compliant.

Macros:

TeX macros can in principle perform calculations on the basis of the value of \year. The LaTeX suite performs such calculations in a small number of places; the calculations performed in the current (supported) version of LaTeX are known to be Y2K compliant.

Other macros and macro packages should be individually checked.

External software:

Software such as DVI translators needs to be individually checked.


What is LaTeX?

LaTeX is a TeX macro package, originally written by Leslie Lamport, that provides a document processing system. LaTeX allows markup to describe the structure of a document, so that the user need not think about presentation. By using document classes and add-on packages, the same document can be produced in a variety of different layouts.

Lamport says that LaTeX ``represents a balance between functionality and ease of use''. This shows itself as a continual conflict that leads to the need for such as the present article: LaTeX can meet most user requirements, but finding out how is often tricky.


How should I pronounce ``LaTeX(2e)''?

Lamport never recommended how one should pronounce LaTeX, but a lot of people pronounce it `Lay TeX' or perhaps `Lah TeX' (with TeX pronounced as the program itself; see the rules for TeX).

The `epsilon' in `LaTeX2e' is supposed to be suggestive of a small improvement over the old LaTeX 2.09. Nevertheless, most people pronounce the name as `LaTeX-two-ee'.


Should I use plain TeX or LaTeX?

There's no straightforward answer to this question. Many people swear by plain TeX, and produce highly respectable documents using it (Knuth is an example of this, of course). But equally, many people are happy to let someone else take the design decisions for them, accepting a small loss of flexibility in exchange for a saving of brain power.

The arguments around this topic can provoke huge amounts of noise and heat, without offering much by way of light; your best bet is to find out what those around you are using, and to go with the crowd. Later on, you can always switch your allegiance; don't bother about it.

If you are preparing a manuscript for a publisher or journal, ask them what markup they want before you develop your own; many big publishers have developed their own LaTeX styles for journals and books, and insist that authors stick closely to their markup.


What is CONTeXT?

CONTeXT is a macro package developed by Hans Hagen, originally to serve the needs of the Dutch firm, Pragma. It was designed with the same general-purpose aims as LaTeX, but (being younger) reflects much more recent thinking about the structure of markup, etc. In particular, CONTeXT can customise its markup to an author's language (customising modules for Dutch, English and German are provided, at present).

CONTeXT is well integrated, in all of its structure, with the needs of hypertext markup, and in particular with the facilities offered by PDFTeX.

CONTeXT doesn't yet have quite such a strong developer community as does LaTeX, but those developers who are active seem to have prodigious energy.

Try a copy, from macros/context.tar.gz


What are the AMS packages (AMSTeX, etc.)?

AMSTeX is a TeX macro package, originally written by Michael Spivak for the American Mathematical Society (AMS) during 1983-1985. It is described in ``The Joy of TeX'' by Michael D. Spivak (second edition, AMS, 1990, ISBN 0-821-82997-1). It is based on plain TeX, and provides many features for producing more professional-looking maths formulas with less burden on authors. It pays attention to the finer details of sizing and positioning that mathematical publishers care about. The aspects covered include multi-line displayed equations, equation numbering, ellipsis dots, matrices, double accents, multi-line subscripts, syntax checking (faster processing on initial error-checking TeX runs), and other things.

As LaTeX increased in popularity, authors asked to submit papers to the AMS in LaTeX, and so the AMS developed AMSLaTeX, which is a collection of LaTeX packages and classes that offer authors most of the functionality of AMSTeX.


What is Eplain?

The Eplain macro package expands on and extends the definitions in plain TeX. Eplain is not intended to provide ``generic typesetting capabilities'', as do LaTeX or Texinfo. Instead, it provides definitions that are intended to be useful regardless of the high-level commands that you use when you actually prepare your manuscript.

For example, Eplain does not have a command \section, which would format section headings in an ``appropriate'' way, as LaTeX's \section. The philosophy of Eplain is that some people will always need or want to go beyond the macro designer's idea of ``appropriate''. Such canned macros are fine - as long as you are willing to accept the resulting output. If you don't like the results, or if you are trying to match a different format, you are out of luck.

On the other hand, almost everyone would like capabilities such as cross-referencing by labels, so that you don't have to put actual page numbers in the manuscript. Karl Berry, the author of Eplain, says he is not aware of any generally available macro packages that do not force their typographic style on an author, and yet provide such capabilities.


What is Lollipop?

Lollipop is a macro package written by Victor Eijkhout; it was used in the production of his book ``TeX by Topic'' (see TeX-related books). The manual says of it:

Lollipop is `TeX made easy'. Lollipop is a macro package that functions as a toolbox for writing TeX macros. It was my intention to make macro writing so easy that implementing a fully new layout in TeX would become a matter of less than an hour for an average document, and that it would be a task that could be accomplished by someone with only a very basic training in TeX programming.

Lollipop is an attempt to make structured text formatting available for environments where previously only WYSIWIG packages could be used because adapting the layout is so much more easy with them than with traditional TeX macro packages.

The manual goes on to talk of ambitions to ``capture some of the LaTeX market share''; it's a very witty package, but little sign of it taking over from LaTeX is detectable... An article about Lollipop appeared in TUGboat 13(3).


What is Texinfo?

Texinfo is a documentation system that uses one source file to produce both on-line information and printed output. So instead of writing two different documents, one for the on-line help and the other for a typeset manual, you need write only one document source file. When the work is revised, you need only revise one document. You can read the on-line information, known as an ``Info file'', with an Info documentation-reading program. By convention, Texinfo source file names end with a .texi or .texinfo extension. You can write and format Texinfo files into Info files within GNU emacs, and read them using the emacs Info reader. If you do not have emacs, you can format Texinfo files into Info files using makeinfo and read them using info.

The Texinfo distribution, including a set of TeX macros for formatting Texinfo files is available as macros/texinfo/texinfo.tar.gz


If TeX is so good, how come it's free?

It's free because Knuth chose to make it so. He is nevertheless apparently happy that others should earn money by selling TeX-based services and products. While several valuable TeX-related tools and packages are offered subject to restrictions imposed by the GNU General Public Licence (`Copyleft'), TeX itself is not subject to Copyleft.

There are commercial versions of TeX available; for some users, it's reassuring to have paid support. What is more, some of the commercial implementations have features that are not available in free versions. (The reverse is also true: some free implementations have features not available commercially.)

Usually, this article does not describe commercial versions; see major vendors for some details.


What is the future of TeX?

Knuth has declared that he will do no further development of TeX; he will continue to fix any bugs that are reported to him (though bugs are rare). This decision was made soon after TeX version 3.0 was released; at each bug-fix release the version number acquires one more digit, so that it tends to the limit pi (at the time of writing, Knuth's latest release is version 3.14159). Knuth wants TeX to be frozen at version pi when he dies; thereafter, no further changes may be made to Knuth's source. (A similar rule is applied to Metafont; its version number tends to the limit e, and currently stands at 2.718.)

There are projects (some of them long-term projects: see, for example, the LaTeX3 project) to build substantial new macro packages based on TeX. For the even longer term, there are various projects to build a successor to TeX; see the Omega project and NTS.


What are TUG and TUGboat?

TUG is the TeX Users Group. TUGboat is TUG's main journal, containing useful articles about TeX and Metafont. TUG also produces a newsletter for members (TeX and TUG News), organises a yearly conference, runs training courses, sells almost all TeX-related books, and distributes TeX-related microcomputer software on disk. TUG has a Technical Council to coordinate TeX-related developments (TUG Technical Working Groups). Enquiries should be directed to:

TeX Users Group
1466 NW Front Avenue, Suite 3141
Portland, OR 97209
USA
Tel: +1 503-223-9994
Fax: +1 503-223-3960
Email: tug@mail.tug.org
Web: http://www.tug.org/
CTAN details: usergrps/tug.tar.gz


Are there nationally-based user groups, too?

The following groups publish their membership (etc.) information electronically on CTAN archives:

DANTE, Deutschsprachige Anwendervereinigung TeX e.V.
Postfach 10 18 40
D-69008 Heidelberg
Germany
Tel: +49 06221 2 97 66
Fax: +49 06221 16 79 06
Email: dante@dante.de
Web: http://www.dante.de/
CTAN details: usergrps/dante.tar.gz

Association GUTenberg,
BP 10,
93220 Gagny principal,
France
Email: secretariat@gutenberg.eu.org
Web: http://www.gutenberg.eu.org/
CTAN details: usergrps/gut.tar.gz

NTG
Postbus 394, 1740AJ Schagen,
The Netherlands
Email: ntg@nic.surfnet.nl
Web: http://www.ntg.nl/
CTAN details: usergrps/ntg.tar.gz

UK TeX Users' Group,
Membership enquiries: c/o Dr James Foster,
School of Mathematical Sciences
University of Sussex
Falmer, Brighton BN1 9QH
United Kingdom
Tel: +44 1273 678781
Fax: +44 1273 678097
Email: j.foster@sussex.ac.uk
General enquiries: uktug-enquiries@tex.ac.uk
Web: http://uk.tug.org/uk-tug

A listing of all known groups is available as usergrps/info/usergrps.tex


TUG Technical Working Groups

TUG has an autonomous Technical Council which can appoint Technical Working Groups related to the specific areas of interest to the TeX community. Each group has a chair/contact person and establishes its own working methods and membership; anyone interested in taking part should contact the group's chair person. Suggestions for new groups should be addressed to tech-council@tug.org; a list of members of the Technical Council can be found at http://tug.org/committees.html

Below is a brief list of currently active groups:

WG-92-01

TeX Extended Mathematics Font Encoding.
To create font encoding standards for Mathematical fonts used in TeX systems.

Contact: Barbara Beeton (bnb@math.ams.org)

WG-92-05

TeX Archive Guidelines.
To develop guidelines for the effective management and utilisation of major TeX archives, and to initiate communication among the maintainers of the existing archives for the purpose of coordination and synchronisation.

Contact: Sebastian Rahtz (s.rahtz@elsevier.co.uk)

WG-94-07

TeX Directory Structure.
To identify a universal directory structure for macros, fonts and other related TeX software so that recommendations can be made to all suppliers of TeX software.

The group's current set of proposals are to be found on CTAN at tds/draft-standard/tds-0.9996.tar.gz

Contact: Karl Berry (kb@cs.umb.edu)

WG-94-08

DVI Driver Implementation and Standardisation Issues.
To study the issues in the requirements of DVI Drivers imposed by changing needs and technologies, and to make recommendations for implementation and standardisation of such drivers to enhance the uniformity of their use. Work will include, but not be limited to, the examination of the use, syntax, and semantics of \special{..} commands.

Contact: Michael Sofka (sofkam@rpi.edu)

WG-94-10

TeX and Linguistics.
To study and discuss the requirements for typesetting linguistics in TeX and as a means of identifying, examining, testing, and comparing macros, fonts, style files and other aids for typesetting linguistics.

Contact: Christina Thiele (cthiele@ccs.carleton.ca)


Books on TeX and its relations

While Knuth's book is the definitive reference for TeX, there are other books covering TeX:

The TeXbook

by Donald Knuth (Addison-Wesley, 1984, ISBN 0-201-13447-0, paperback ISBN 0-201-13448-9)

A Beginner's Book of TeX

by Raymond Seroul and Silvio Levy, (Springer Verlag, 1992, ISBN 0-387-97562-4)

TeX by Example: A Beginner's Guide

by Arvind Borde (Academic Press, 1992, ISBN 0-12-117650-9)

Introduction to TeX

by Norbert Schwarz (Addison-Wesley, 1989, ISBN 0-201-51141-X)

A Plain TeX Primer

by Malcolm Clark (Oxford University Press, 1993, ISBNs 0-198-53724-7 (hardback) and 0-198-53784-0 (paperback))

TeX by Topic

by Victor Eijkhout (Addison-Wesley, 1992, ISBN 0-201-56882-9)

TeX for the Beginner

by Wynter Snow (Addison-Wesley, 1992, ISBN 0-201-54799-6)

TeX for the Impatient

by Paul W. Abrahams, Karl Berry and Kathryn A. Hargreaves (Addison-Wesley, 1990, ISBN 0-201-51375-7)

TeX in Practice

by Stephan von Bechtolsheim (Springer Verlag, 1993, 4 volumes, ISBN 3-540-97296-X for the set, or Vol. 1: ISBN 0-387-97595-0, Vol. 2: ISBN 0-387-97596-9, Vol. 3: ISBN 0-387-97597-7, and Vol. 4: ISBN 0-387-97598-5)

TeX: Starting from Square One

by Michael Doob (Springer Verlag, 1993, ISBN 3-540-56441-1)

The Advanced TeXbook

by David Salomon (Springer Verlag, 1995, ISBN 0-387-94556-3)

A collection of Knuth's publications about typography has recently been published:

Digital Typography

by Donald Knuth (CSLI and Cambridge University Press, 1999, ISBN 1-57586-011-2, paperback ISBN 1-57586-010-4).

For LaTeX, see:

LaTeX, a Document Preparation System

by Leslie Lamport (second edition, Addison Wesley, 1994, ISBN 0-201-15790-X)

A guide to LaTeX2e

Helmut Kopka and Patrick W. Daly (third edition, Addison-Wesley, 1998, ISBN 0-201-39825-7)

The LaTeX Companion

by Michel Goossens, Frank Mittelbach, and Alexander Samarin (Addison-Wesley, 1993, ISBN 0-201-54199-8)

The LaTeX Graphics Companion:

Illustrating documents with TeX and PostScript by Michel Goossens, Sebastian Rahtz and Frank Mittelbach (Addison-Wesley, 1997, ISBN 0-201-85469-4)

The LaTeX Web Companion

Integrating TeX, HTML and XML by Michel Goossens and Sebastian Rahtz (Addison-Wesley, 1999, ISBN 0-201-43311-7)

TeX Unbound:

LaTeX and TeX strategies for fonts, graphics, and more by Alan Hoenig (Oxford University Press, 1998, ISBN 0-19-509685-1 hardback, ISBN 0-19-509686-X paperback)

Math into TeX:

A Simplified Introduction using AMSLaTeX by George Grätzer (Birkhäuser, 1993, ISBN 0-817-63637-4, or, in Germany, ISBN 3-764-33637-4)

Math into LaTeX:

An Introduction to LaTeX and AMSLaTeX by George Grätzer (Birkhäuser, 1996, ISBN 0-817-63805-9)

First Steps in LaTeX

by George Grätzer (Birkhäuser, 1999, ISBN 0-8176-4132-7)

LaTeX: Line by Line:

Tips and Techniques for Document Processing by Antoni Diller (second edition, John Wiley & Sons, 1999, ISBN 0-471-97918-X)

LaTeX for Linux:

A Vade Mecum by Bernice Sacks Lipkin (Springer-Verlag, 1999, ISBN 0-387-98708-8, second printing)

A list of errata for the first printing is available from: \url{http://www.springer-ny.com/catalog/np/jan99np/0-387-98708-8.html}

A sample of George Grätzer's book, in Adobe Acrobat format, is also available (info/mil/mil.pdf).

Example files for the LaTeX Graphics and Web Companions are available in info/lgc.tar.gz (Graphics) and info/lwc.tar.gz (Web). Example files for George Grätzer's `First Steps' are available in info/FirstSteps.tar.gz

The list for Metafont is rather short:

The Metafontbook

by Donald Knuth (Addison Wesley, 1986, ISBN 0-201-13445-4, ISBN 0-201-52983-1 paperback)

Alan Hoenig's `TeX Unbound' includes some discussion and examples of using Metafont.

This list only covers books in English: UK TUG cannot hope to maintain a list of books in languages other than our own.


Books on Type

The following is a partial listing of books on typography in general. Of these, Bringhurst seems to be the one most often recommended.

The Elements of Typographic Style

by Robert Bringhurst (Hartley & Marks, 1992, ISBN 0-88179-033-8)

Finer Points in the Spacing & Arrangement of Type

by Geoffrey Dowding (Hartley & Marks, 1996, ISBN 0-88179-119-9)

The Thames & Hudson Manual of Typography

by Ruari McLean (Thames & Hudson, 1980, ISBN 0-500-68022-1)

The Form of the Book

by Jan Tschichold (Lund Humphries, 1991, ISBN 0-85331-623-6)

Type & Layout

by Colin Wheildon (Strathmore Press, 1995, ISBN 0-9624891-5-8)

The Design of Books

by Adrian Wilson (Chronicle Books, 1993, ISBN 0-8118-0304-X)

There are many catalogues of type specimens but the following books provide a more interesting overall view of types in general and some of their history.

Alphabets Old & New

by Lewis F. Day (Senate, 1995, ISBN 1-85958-160-9)

An Introduction to the History of Printing Types

by Geoffrey Dowding (British Library, 1998, UK ISBN 0-7123-4563-9; USA ISBN 1-884718-44-2)

The Alphabet Abecedarium

by Richar A. Firmage (David R. Goodine, 1993, ISBN 0-87923-998-0)

The Alphabet and Elements of Lettering

by Frederick Goudy (Dover, 1963, ISBN 0-486-20792-7)

Anatomy of a Typeface

by Alexander Lawson (David R. Goodine, 1990, ISBN 0-87923-338-8)

A Tally of Types

by Stanley Morison (David R. Goodine, 1999, ISBN 1-56792-004-7)

Counterpunch

by Fred Smeijers (Hyphen, 1996, ISBN 0-907259-06-5)

Treasury of Alphabets and Lettering

by Jan Tschichold (W. W. Norton, 1992, ISBN 0-393-70197-2)

The above lists are limited to books published in English. Typographic styles are somewhat language-dependent, and similarly the `interesting' fonts depend on the particular writing system involved.


Where to find this article

Bobby Bodenheimer's article, from which the present one was developed, used to be posted (nominally monthly) to newsgroup comp.text.tex and cross-posted to newsgroups news.answers and comp.answers. The most recently posted copy of that article is kept on CTAN in directory obsolete/help.tar.gz; it is no longer kept in the news.answers archives.

The sources of the article are available from usergrps/uktug/faq.tar.gz

Both the Francophone TeX usergroup Gutenberg and the Czech/Slovak usergroup CS-TUG have published translations of this FAQ, with extensions appropriate to their languages.

In addition, the German usergroup Dante posts a FAQ in German to de.comp.tex, which is archived as usergrps/dante/de-tex-faq.tar.gz, and Marie-Paule Kluth posts a FAQ in French to fr.comp.text.tex, which is archived as help/LaTeX-FAQ-francaise.tar.gz


Where to get help

First \dots read any FAQ you can find. (Which is what you're doing now, isn't it?)

The tutorials and other on-line documentation can get you started but for more in-depth understanding you should get and read at least one of the many good books on the subject (Qref{Q-books}). The definitive source for (La)TeX is the source code itself, but that is not something to be approached lightly (if at all).

If you are seeking a particular package or program, look on your own system first: you might already have it.

If you have access to the internet, and in particular newsgroups, then (La)TeX discussions, including Metafont and MetaPost, are on comp.text.tex. It is best to spend a little time familiarising yourself with the current threads before asking a question. The group is normally very responsive but asking a question that has just been answered is likely to dampen people's enthusiasm to help you. In case you are not familiar with some of the abbreviations used in newsgroup postings, RTFM stands for `Read The ... Manual', and you don't really want to get that response, do you?

http://www.deja.com/usenet makes a good job of archiving Usenet news discussions, and comp.text.tex may be found there. If your internet access doesn't include direct access to Usenet news, you can participate in discussions via Deja.

The few people who can't use the World Wide Web, can't access Usenet news, but can use electronic mail can seek help through mailing lists.

The TeXhax digest is operated as a mailing list. Send a message `subscribe texhax' to texhax-request@tex.ac.uk to join it. Its turn-around is not rapid, but questions submitted to it do eventually get answered.

Many mailing lists exist that cover some small part of the TeX arena. A good source of pointers is http://www.tug.org/

Announcements of TeX-related installations on the CTAN archives are sent to the mailing list ctan-ann. Subscribe to the list by sending a message `subscribe ctan-ann <your name>' to listserv@urz.Uni-Heidelberg.de

Issues related to Metafont (and, increasingly, MetaPost) are discussed on the metafont mailing list; subscribe by sending a message `subscribe metafont <your name>' to listserv@ens.fr

Several other TeX-related lists may be accessed via listserv@urz.uni-heidelberg.de. Send a message containing the line `help' to this address.


(La)TeX Tutorials

Some very fine tutorials have been written, over the years. Michael Doob's splendid `Gentle Introduction' to plain TeX has been stable for a very long time. See info/gentle/gentle.pdf

More dynamic is Tobias Oetiker's `(Not so) Short Introduction to LaTeX2e', which is regularly updated, as people suggest better ways of explaining things, etc. See info/lshort/english/lshort.pdf

A recent entrant is Harvey Greenberg's `Simplified Introduction to LaTeX'; this was written for a lecture course, and is available (PostScript only, unfortunately) as info/simplified-latex/latex.ps


Metafont and MetaPost Tutorials

Unfortunately there appear to be no tutorials on how to use either Metafont or MetaPost, except for the information provided by their respective authors. There are, though, a couple of articles on how to run the programs.

Geoffrey Tobin has provided Metafont for Beginners which is available as info/metafont-for-beginners.tex (Qref{Q-mf}). This describes how the Metafont system works and how to avoid some of the potential pitfalls.

Peter Wilson's Some Experiences in Running Metafont and MetaPost is available at info/metafp.ps (PostScript) or info/metafp.pdf (PDF format). On the Metafont side the article is more geared towards testing and installing new Metafont fonts than on the system, while on the other side it describes how to use MetaPost illustrations in LaTeX and PDFLaTeX documents, with an emphasis on how to use appropriate fonts for any text or mathematics.


BibTeX Documentation

BibTeX, a program originally designed to produce bibliographies in conjunction with LaTeX, is explained in Section 4.3 and Appendix B of Leslie Lamport's LaTeX manual (see TeX-related books). The document ``BibTeXing'', contained in the file btxdoc.tex, gives a more complete description. The LaTeX Companion (see TeX-related books) also has information on BibTeX and writing BibTeX style files.

The document ``Designing BibTeX Styles'', contained in the file btxhak.tex, explains the postfix stack-based language used to write BibTeX styles (.bst files). The file btxbst.doc is the template for the four standard styles (plain, abbrv, alpha, unsrt). It also contains their documentation. The complete BibTeX documentation set (including the files above) is in biblio/bibtex/distribs/doc.tar.gz

There is a Unix BibTeX man page in the web2c package (see TeX systems). Any copy you may find of a man page written in 1985 (before ``BibTeXing'' and ``Designing BibTeX Styles'' appeared) is obsolete, and should be thrown away.


The PiCTeX manual

PiCTeX is a set of macros by Michael Wichura for drawing diagrams and pictures. The macros are freely available in graphics/pictex.tar.gz; however, the PiCTeX manual itself is not free. Unfortunately, TUG is no longer able to supply copies of the manual (as it once did), and it is now available only through Personal TeX Inc, the vendors of PCTeX (http://www.pctex.com/). The manual is not available electronically.


Finding (La)TeX macro packages

Before you ask for a TeX macro or LaTeX class or package file to do something, try searching Graham Williams' catalogue, available as help/Catalogue/catalogue.html, or for efficient interactive searching via http://www.tex.ac.uk/tex-archive/help/Catalogue/catalogue.html; this lists many macro packages together with brief descriptive texts.

Having learnt of a file that seems interesting, search a CTAN archive for it (see finding files on CTAN). For packages listed in The LaTeX Companion the file info/companion.ctan may be consulted as an alternative to searching the archive's index. It lists the current location in the archive of such files.


Finding files in the CTAN archives

To find software at a CTAN site, you can use anonymous ftp to the host with the command `quote site index <term>', or the searching script at http://www.dante.de/cgi-bin/ctan-index

To get the best use out of the ftp facility you should remember that <term> is a Regular Expression and not a fixed string, and also that many files are distributed in source form with an extension different to the final file. (For example LaTeX packages are often distributed sources with extension dtx rather than as package files with extension sty.)

One should make the regular expresion general enough to find the file you are looking for, but not too general, as the ftp interface will only return the first 20 lines that match your request.

The following examples illustrate these points. To search for the LaTeX package `caption', you might use the command:

  quote site index caption.sty

but it will fail to find the desired package (which is distributed as caption.dtx) and does return unwanted `hits' (such as hangcaption.sty). Also, although this example does not show it the `.' in `caption.sty' is used as the regular expression that matches any character. So

  quote site index doc.sty

matches such unwanted files as language/swedish/slatex/doc2sty/makefile

Of course if you know the package is stored as .dtx you can search for that name, but in general you may not know the extension used on the archive. The solution is to add `/' to the front of the package name and `
. to the end. This will then search for a file name that consists solely of the package name between the directory separator and the extension. The two commands:

  quote site index /caption\\.
  quote site index /doc\\.

do narrow the search down sufficiently. (In the case of doc, a few extra files are found, but the list returned is sufficiently small to be easily inspected.)

If the search string is too wide and too many files would match, the list will be truncated to the first 20 items found. Using some knowledge of the CTAN directory tree you can usually narrow the search sufficiently. As an example suppose you wanted to find a copy of the dvips driver for MSDOS. You might use the command:

  quote site index dvips

but the result would be a truncated list, not including the file you want. (If this list were not truncated 412 items would be returned!) However we can restrict the search to MSDOS related drivers as follows.

  quote site index msdos.*dvips

Which just returns relevant lines such as systems/msdos/dviware/dvips/dvips5528.zip

A basic introduction to searching with regular expressions is:

  • Most charcters match themselves, so "a" matches "a" etc.;

  • "." matches any character;
  • "[abcD-F]" matches any single character from the set {"a","b","c","D","E","F"};
  • "*" placed after an expression matches zero or more occurrences so "a*" matches "a" and "aaaa", and "[a-zA-Z]*" matches a `word';
  • "\" `quotes' a special character such as "." so "\." just matches ".";
  • "^" matches the beginning of a line;
  • "$" matches the end of a line.

For technical reasons in the quote site index command, you need to `double' any \ hence the string /caption\\. in the above example. The quote site command ignores the case of letters. Searching for caption or CAPTION would produce the same result.


What is a DVI file?

A DVI file (that is, a file with the type or extension .dvi) is TeX's main output file, using TeX in its broadest sense to include LaTeX, etc. `DVI' is supposed to be an acronym for DeVice-Independent, meaning that the file can be printed on almost any kind of typographic output device. The DVI file is designed to be read by a driver (DVI drivers) to produce further output designed specifically for a particular printer (e.g., a LaserJet) or to be used as input to a previewer for display on a computer screen. DVI files use TeX's internal coding; a TeX input file should produce the same DVI file regardless of which implementation of TeX is used to produce it.

A DVI file contains all the information that is needed for printing or previewing except for the actual bitmaps or outlines of fonts, and possibly material to be introduced by means of \special commands.

The canonical reference for the structure of a DVI file is the source of dvitype (systems/knuth/texware/dvitype.web).


What is a driver?

A driver is a program that takes as input a dvi file (DVI files) and (usually) produces a file that can be sent to a typographic output device, called a printer for short.

A driver will usually be specific to a particular printer, although any PostScript printer ought to be able to print the output from a PostScript driver.

As well as the DVI file, the driver needs font information. Font information may be held as bitmaps or as outlines, or simply as a set of pointers into the fonts that the printer itself `has'. Each driver will expect the font information in a particular form. For more information on the forms of fonts, see questions pk files, tfm files, virtual fonts and Using PostScript fonts with TeX.


What are PK files?

PK files (packed raster) contain font bitmaps. The output from Metafont includes a generic font (GF) file and the utility gftopk produces the PK file from that. There are a lot of PK files, as one is needed for each font, that is each magnification (size) of each design (point) size for each weight for each family. Further, since the PK files for one printer do not necessarily work well for another, the whole set needs to be duplicated for each printer type at a site. As a result, they are often held in an elaborate directory structure, or in `font library files', to regularise access.


What are TFM files?

TFM stands for TeX font metrics, and TFM files hold information about the sizes of the characters of the font in question, and about ligatures and kerns within that font. One TFM file is needed for each font used by TeX, that is for each design (point) size for each weight for each family; one TFM file serves for all magnifications, so that there are (typically) fewer TFM files than there are PK files. The important point is that TFM files are used by TeX (LaTeX, etc.), but are not, generally, needed by the printer driver.


Virtual fonts

Virtual fonts for TeX were first implemented by David Fuchs in the early days of TeX, but for most people they started when Knuth redefined the format, and wrote some support software, in 1989. Virtual fonts provide a way of telling TeX about something more complicated than just a one-to-one character mapping. The entities you define in a virtual font look like characters to TeX (they appear with their sizes in a font metric file), but the DVI processor may expand them to something quite different. You can use this facility just to remap characters, to make a composite font with glyphs drawn from several sources, or to build up an effect in arbitrarily complicated ways - a virtual font may contain anything which is legal in a DVI file. In practice, the most common use of virtual fonts is to remap PostScript fonts (see font metrics) or to build `fake' maths fonts.

It is important to realise that TeX itself does not see virtual fonts; for every virtual font read by the DVI driver there is a corresponding TFM file read by TeX. Virtual fonts are normally created in a single ASCII vpl (Virtual Property List) file, which includes both sets of information. The vptovf program is then used to the create the binary TFM and VF files. The commonest way (nowadays) of generating vpl files is to use the fontinst package, which is described in detail together with the discussion of PostScript font metrics. fonts/utilities/qdtexvpl.tar.gz is another utility for creating ad-hoc virtual fonts.


\special commands

TeX provides the means to express things that device drivers can do, but about which TeX itself knows nothing. For example, TeX itself knows nothing about how to include PostScript figures into documents, or how to set the colour of printed text; but some device drivers do.

Such things are introduced to your document by means of \special commands; all that TeX does with these commands is to expand their arguments and then pass the command to the DVI file. In most cases, there are macro packages provided (often with the driver) that provide a comprehensible interface to the \special; for example, there's little point including a figure if you leave no gap for it in your text, and changing colour proves to be a particularly fraught operation that requires real wizardry. LaTeX2e has standard graphics and colour packages that make file inclusion, rotation, scaling and colour via \specials all easy.

The allowable arguments of \special depend on the device driver you're using. Apart from the examples above, there are \special commands in the emTeX drivers (e.g., dvihplj, dviscr, etc.) that will draw lines at arbitrary orientations, and commands in dvitoln03 that permit the page to be set in landscape orientation.


Documented LaTeX sources (.dtx files)

LaTeX2e, and many support macro packages, are now written in a literate programming style, with source and documentation in the same file. This format, known as `doc', was originated by Frank Mittelbach. The documented sources conventionally have the suffix .dtx, and should normally be stripped of documentation before use with LaTeX. Alternatively you can run LaTeX on a .dtx file to produce a nicely formatted version of the documented code. An installation script (with suffix .ins) is usually provided, which needs the standard LaTeX2e docstrip package (among other things, the installation process strips all the comments that make up the documentation for speed when loading the file into a running LaTeX system). Several packages can be included in one .dtx file, with conditional sections, and there facilities for indices of macros etc. Anyone can write .dtx files; the format is explained in The LaTeX Companion (see books on TeX). There are no programs yet to assist in composition.

.dtx files are not used by LaTeX after they have been processed to produce .sty or .cls (or whatever) files. They need not be kept with the working system; however, for many packages the .dtx file is the primary source of documentation, so you may want to keep .dtx files elsewhere.


What are the EC fonts?

A font consists of a number of glyphs. In order that the glyphs may be printed, there has to be some way of accessing them; in TeX they're arranged in a numerical order called an encoding, and their number in the encoding is used. For various reasons, Knuth chose rather eccentric encodings; in particular, he chose different encodings for different fonts.

When TeX version 3 arrived, some at least of the reasons for the eccentricity of Knuth's encodings went away, and at TUG's Cork meeting, an encoding for a set of 256 glyphs, for use in TeX text, was defined. The intention was that these glyphs should cover `most' European languages, in the sense of including all accented letters needed. (Knuth's CMR fonts missed things necessary for Icelandic, Polish and Sami, for example, but the Cork fonts have them.) LaTeX2e refers to the Cork encoding as T1, and provides the means to use fonts thus encoded to avoid problems with the interaction of accents and hyphenation (see hyphenation of accented words).

The only Metafont-fonts that conform to the Cork encoding are the EC fonts (available as fonts/ec.tar.gz). They look CM-like, and are now regarded as `stable' (in the same sense that the CM fonts are stable: their metrics are unlikely ever to change). Their serious disadvantage for the casual user is that they are large - each EC font is roughly twice the size of the corresponding CM font; what's more, until corresponding fonts for mathematics are produced, the CM fonts must be retained.

The EC fonts supersede the experimental DC fonts, which have now been removed from the archives. They are distributed with a set of `Text Companion' (TC) fonts that provide glyphs for symbols commonly used in text. The TC fonts are encoded according to the LaTeX TS1 encoding, and are not viewed as `stable' in the same way as are the EC fonts are.

The Cork encoding is also implemented by the PSNFSS system, for PostScript fonts.


What is TDS?

TDS stands for the TeX Directory Structure, which is a standard way of organising all the \TeX -related files on a computer system. The TDS specification can be found on CTAN in tds/draft-standard/tds-0.9996.tar.gz

Most modern distributions conform to the TDS, which provides for both a `standard' hierarchy and a `local' hierarchy. The TDS reserves the name texmf as the name of the root directory (folder) of the hierachies. Files supplied as part of the distribution are put into the standard hierarchy. The location of the standard hierarchy is system dependent, but on a Unix system it might be at /usr/local/texmf, or /usr/local/share/texmf, or /opt/texmf, or a similar location, but in each case the TeX files will be under the /texmf subdirectory.

There can be multiple `local' hierarchies in which additional files can be put. In the extreme an installation can have a local hierarchy and each user can also have an individual local hierarchy. The location of any local hierarchy is not only system dependent but also user dependent. Again, though, all files should be put under a local /texmf directory.


Repositories of TeX material

To aid the archiving and retrieval of of TeX-related files, a TUG working group developed the Comprehensive TeX Archive Network (CTAN). Each CTAN site has identical material, and maintains authoritative versions of its material. These collections are extensive; in particular, almost everything mentioned in this article is archived at the CTAN sites, even if its location isn't explicitly stated.

The CTAN sites are currently dante.ctan.org (Mainz, Germany), cam.ctan.org (Cambridge, UK) and tug.ctan.org (Colchester, Vermont, USA). Two of the CTAN web servers offer a search facility: http://www.tex.ac.uk/search and http://www.ctan.org/search; you can look for a file whose name you already know, or you can do a keyword-based search of the catalogue. The search script requires that you choose an appropriate CTAN site or mirror to retrieve files from, and stores details of that site in a cookie on your machine. Choose a site that is close to you, to reduce network load.

The organisation of TeX files on all CTAN sites is identical and starts at tex-archive/. Again, to reduce network load, please use the CTAN site or mirror closest to you. A complete and current list of CTAN sites and known mirrors can be obtained by using the finger utility on `user' ctan@cam.ctan.org, ctan@dante.ctan.org or ctan@tug.ctan.org; it is also available as file CTAN.sites

To find software at a CTAN site using anonymous ftp to the host, execute the command `quote site index <term>' (see finding files for details).

The email servers ftpmail@dante.ctan.org and ftpmail@tug.ctan.org provide an ftp-like interface through mail. Send a message containing just the line `help' to your nearest server, for details of use.

There is also the DECUS TeX collection of material for VMS, Unix, MSDOS, and the Macintosh. It is available via anonymous ftp from wuarchive.wustl.edu (128.252.135.4) in decus/tex/. It can also be obtained from the DECUS Library (reference number VS0058) in the US, or through your DECUS office outside of the US. To contact the DECUS Library, send mail or telephone:

DECUS
LIBRARY ORDER PROCESSING
334 South Street, SHR3-1/T25
Shrewsbury, MA 01545-4195
USA
Tel: 800-DECUS55 (within the USA, for information)
Fax: +1 508-841-3373 (for inquiries)

or send electronic mail for information to the DECUS TeX Collection Editor, Ted Nieland (nieland@ted.hcst.com).

Finally, of course, the TeX user who has no access to any sort of network may buy a copy of the archive on CDROM (see TeX CDROMs).


What's the CTAN nonfree tree?

The CTAN archives are currently restructuring their holdings so that files that are `not free' are held in a separate tree. The definition of what is `free' (for this purpose) is influenced by, but not exactly the same as the Debian Free Software Guidelines (DFSG: see http://www.debian.org/social_contract#guidelines).

Material is placed on the nonfree tree if it is not freely-usable (e.g., if the material is shareware, commercial, or if its usage is not permitted in certain domains at all, or without payment). Users of the archive should check that they are entitled to use material they have retrieved from the nonfree tree.

For details of the licence categories, see http://www.tex.ac.uk/tex-archive/help/Catalogue/licenses.html


Contributing a file to the archives

Use anonymous ftp to any CTAN archive (see sources of software) and retrieve the file README.uploads in the root directory. It contains instructions for uploading files and notifying the appropriate people for that site.

If you cannot use ftp, mail your contribution to ctan@urz.Uni-Heidelberg.de and it will be passed along. You will make everyone's life easier if you choose a descriptive and unique name for your submission, so it's probably a good idea to check that your style file's name is not already in use by means of the `site index' command (finding files in the archives).


Finding new fonts

A comprehensive list of Metafont fonts is posted to comp.fonts and to comp.text.tex, roughly every six weeks, by Lee Quin (lee@sq.sq.com); it is available as info/metafont-list

The list contains details both of commercial fonts and of fonts available via anonymous ftp. Most of the fonts are available via anonymous ftp from the CTAN archives (see sources of software).


TeX CDROMs

If you don't have access to the Internet, there are obvious attractions to TeX collections on a CDROM. Even those with net access will find large quantities of TeX-related files to hand a great convenience.

Ready-to-run TeX systems on CDROM are available:

  • A consortium of User Groups (notably TUG, UK TUG and GUTenberg) distribute the TeX Live CDROM, now in its third edition. All members of several User Groups are receiving copies, and additional copies may be purchased, for example, from UK TUG for &pound;25, including an edition of Baskerville which serves as a manual.

    On-line details of TeX Live are available at http://www.tug.org/texlive.html

  • The Dutch TeX Users Group (NTG) publish the whole 4AllTeX workbench on a 2-CDROM set packed with all the MSDOS TeX software, macros and fonts you can want. It is available from NTG direct (see user groups), from TUG for $40 and from UK TUG for &pound;30 (a manual is included). It is a useful resource for anyone to browse, not just for MSDOS users.

An alternative to the ready-to-run system is the CTAN archive snapshot; in general one would expect that such systems would be harder to use, but that the volume of resources offered would balance this extra inconvenience.

Walnut Creek CDROM provide a two-disc CDROM set, holding 1000Mb of TeX-related material. Information about the CDROM is available at http://www.cdrom.com/titles/prog/tex.html, which also has a link to an ordering page. Walnut Creek's address, etc., are:

Walnut Creek CDROM
4041 Pike Lane, Ste D-www
Concord, CA 94520
USA
Tel: +1 510 674-0783 or 800 786-9907 (within the USA and Canada)
Fax: +1 510 674-0821
Email: info@cdrom.com (for questions) and orders@cdrom.com (for orders)

Walnut Creek (who run one of the major CTAN mirrors) are rumoured to be producing a new release of their disc set in 1997.

Prime Time Freeware produced TeXcetera 1.1 in July 1994, which was a snapshot of CTAN taken in June 1994. Regular updates were planned (but have not apparently been forthcoming). The material is all compressed in ZIP format to fit it all on one CD, and to avoid the limitations of the ISO 9660 file system directory. You can buy the CD from:

Prime Time Freeware
370 Altair Way, Suite 150
Sunnyvale CA 94086
USA
Tel: +1 408 433 9662
Fax: +1 408 433 0727
Email: ptf@cfcl.com

or from many CDROM resellers, or the TUG office. Price will be around $60. Please note that PTF is not a big commercial firm, and is a good friend of the TeX community.


(La)TeX for different machines

We list here the free or shareware packages; another question addresses commercial TeX vendors' products.

Unix

Instructions for retrieving the Unix TeX distribution via anonymous ftp are available in the document systems/unix/unixtex.ftp, though nowadays the sensible installer will take (and possibly customise) one of the packaged distributions such as teTeX , or the TeX Live CDROM (see TeX CDROMs).

For teTeX, browse systems/unix/teTeX/1.0/distrib/sources/ for relevant files: you need at most one each of the .tar.gz files for teTeX-src, teTeX-texmf and teTeX-texmfsrc

Sets of binaries for many common Unix systems are to be found as part of the teTeX distribution, or on the TeX Live CDROM. For teTeX binaries, browse systems/unix/teTeX/1.0/distrib/binaries/ - there's a compressed .tar archive for each supported architecture in the directory. In default of a precompiled version, teTeX will compile on most Unix systems, though it was originally developed for use under Linux (see below).

Linux

There are at least two respectable implementations of TeX to run on Linux, NTeX (available as systems/unix/linux/ntex.tar.gz) and teTeX (browse systems/unix/teTeX/1.0/distrib/sources/).

Beware the Slackware '96 CDROM distribution of NTeX: it includes a version of the CM fonts that has deeply offended Don Knuth (since it contravenes his distribution conditions). The Slackware updates now offer teTeX, as do most Linux distributions.

PC

The emTeX package for PCs running OS/2, MSDOS or Windows includes LaTeX, BibTeX, previewers, and drivers, and is available in systems/msdos/emtex.tar.gz as a series of zip archives. The package was written by Eberhard Mattes, and documentation is available in both German and English. Appropriate memory managers for using emTeX with 386 (and better) processors and under Windows, are included in the distribution.

The most recent offering is an MSDOS port of the Web2C 7.0 implementation, using the GNU djgpp compiler. It is available from systems/msdos/djgpp.tar.gz

PC: Win32

fpTeX, by Fabrice Popineau, is a version of teTeX for Windows systems. As such, it is particularly attractive to those who need to switch back and forth between Windows and Unix environments, and to administrators who need to maintain both (fpTeX can use the same texmf tree as a teTeX installation). fpTeX's previewer (Windvi) is based on xdvi, and takes advantage of extra facilities in the Win32 environment. Printing is available via dvips only. fp\TeX is available from systems/win32/fptex.tar.gz

MikTeX, by Christian Schenk, is also a comprehensive distribution, developed separately from the teTeX work. It has its own previewer, YAP, which is itself capable of printing, though the distribution also includes a port of dvips. See http://www.tex.ac.uk/tex-archive/systems/win32/miktex/ for downloading details.

Windows NT, other platforms

A Power PC port of MikTeX is available from systems/win32/miktexppc.tar.gz, and an AXP port is available from systems/win32/miktex-AXP.tar.gz; these versions have not been updated for version 1.2 (and later) of MikTeX - they may not be satisfactory.

Mac

OzTeX is a shareware version of TeX for the Macintosh. A DVI previewer and PostScript driver are also included. It should run on any Macintosh Plus, SE, II, or newer model, but will not work on a 128K or 512K Mac. It was written by Andrew Trevorrow, and is available in nonfree/systems/mac/oztex.tar.gz

UK TUG prepays the shareware fee, so that its members may acquire the software without further payment. Questions about OzTeX may be directed to oztex@midway.uchicago.edu

Another partly shareware program is CMacTeX (available as systems/mac/cmactex.tar.gz), put together by Tom Kiffe. This is much closer to the Unix TeX setup (it uses dvips, for instance). CMacTeX includes a port of the latest version of Omega.

A useful resource for Mac users is to be found at http://www.esm.psu.edu/mac-tex/; it has a news and `help' section, as well as details of systems and tools.

OpenVMS

TeX for OpenVMS is available as systems/OpenVMS/TEX97_CTAN.ZIP

Standard tape distribution is through DECUS (see sources of software).

Atari

TeX is available for the Atari ST in systems/atari.tar.gz

If anonymous ftp is not available to you, send a message containing the line `help' to atari@atari.archive.umich.edu

Amiga

Full implementations of TeX 3.1 (PasTeX) and Metafont 2.7 are available in systems/amiga.tar.gz

You can also order a CDROM containing this and other Amiga software from Walnut Creek CDROM, telephone +1 510-947-5997.

TOPS-20

TeX was originally written on a DEC-10 under WAITS, and so was easily ported to TOPS-20. A distribution that runs on TOPS-20 is available via anonymous ftp from ftp.math.utah.edu (128.110.198.34) in pub/tex/pub/web


TeX-friendly editors and shells

There are good TeX-writing environments and editors for most operating systems; some are described below, but this is only a personal selection:

Unix

Try GNU emacs, and the AUCTeX mode (support/auctex.tar.gz). This provides menu items and control sequences for common constructs, checks syntax, lays out markup nicely, lets you call TeX and drivers from within the editor, and everything else like this that you can think of. Complex, but very powerful.

VMS

An lsedit mode for editing TeX source is available from TUG as TeXniques 1, VAX Language-Sensitive Editor, by Kent MacPherson (1985).

MSDOS

There are several choices:
  • The (shareware) 4AllTeX workbench (systems/msdos/4alltex.tar.gz) provides a very comprehensive environment written in 4DOS which lets you access most TeX-related software in a friendly way. You can choose your own editor; something such as QEdit or Brief is suitable. This whole package is available in easy-to-use form on CDROM from TeX user groups.
  • TeXshell (systems/msdos/texshell.tar.gz) is a simpler, easily-customisable environment, which can be used with the editor of your choice.
  • Eddi4TeX (systems/msdos/e4t.tar.gz; also shareware) is a specially-written TeX editor which features intelligent colouring, bracket matching, syntax checking, online help and the ability to call TeX programs from within the editor. It is highly customisable, and features a powerful macro language.
You can also use GNU emacs and AUCTeX under MSDOS.

Windows 3.1

Your best public domain bet is probably to use MicroEmacs as an editor and control centre for TeX programs.

TeXtelmExtel (systems/msdos/emtex-contrib/TeXtelmExtel.tar.gz) is a Shell for emTeX or WTeX and related tools under Windows. It includes a simple multiple-document editor, a built-in spelling checker, automatic OEM/ANSI character conversion, user-definable point-and-click Templates, support for the forward and inverse search mechanism of DVI driver for Windows and for automatic font generation. Besides the predefined tools, up to 10 user-defined tools can be set up.

On a PC with large enough memory, a version of GNU emacs, that will run under Windows, is available; thus you can also use AUCTeX under Windows.

Y&Y's commercial (and high-quality) Windows previewer, dviwindo, can be used as a good TeX shell, calling programs such as TeX, drivers, and editors (Y&Y supply the public domain PE, and recommend the commercial Epsilon) from customisable menus (see commercial vendors for details of Y&Y).

Scientific Word is a WYSIWIG editing program, strong on maths, which uses LaTeX for output (see vendors for contact address).

Windows '9x, NT

Winedt, a shareware package (systems/win32/winedt/winedt32.exe), is highly spoken of. It provides a shell for the use of tex and related programs, as well as a powerful and well-configured editor.

OS/2

Eddi4TeX works under OS/2; look also at systems/os2/epmtex.tar.gz for a specific OS/2 shell.

Macintosh

The commercial Textures provides an excellent integrated Macintosh environment with its own editor. More powerful still (as an editor) is the shareware Alpha (systems/mac/support/alpha.tar.gz) which is extensible enough to let you perform almost any TeX-related job. It works well with OzTeX.

Atari, Amiga and NeXT users also have nice environments. LaTeX users who like make should try support/latexmk.tar.gz

There is another set of shell programs to help you manipulate BibTeX databases.


Commercial TeX implementations

There are many commercial implementations of TeX. The first appeared not long after TeX itself appeared. Of the vendors, ArborText (formerly Textset) and Personal TeX are those who have survived longest (since the mid or early 80s).

What follows is probably an incomplete list. Naturally, no warranty or fitness for purpose is implied by the inclusion of any vendor in this list. The source of the information is given to provide some clues to its currency.

In general, a commercial implementation will come `complete', that is, with suitable previewers and printer drivers. They normally also have extensive documentation (i.e., not just the TeXbook!) and some sort of support service. In some cases this is a toll free number (probably applicable only within the USA and or Canada), but others also have email, and normal telephone and fax support.

Unix; TeX

Silicon Graphics Iris/Indigo, Solaris 2.1, IBM RS/6000, DEC/RISC-Ultrix, HP 9000. ``Complete TeX packages. Ready to use, fully documented and supported.''

ArborText Inc
1000 Victors Way
Suite 400
Ann Arbor MI 48108
USA
Tel: +1 313-996-3566
Fax: +1 313-996-3573

Source: TUGboat 15(1) (1994)

VAX/VMS; Convergent TeX

Complete system for VAX/VMS machines (a version for Alphas is in preparation); includes LaTeX, multinational typesetting support, Metafont and Web.

Northlake Software, Inc.
812 SW Washington, Ste 1100
Portland, OR 97201
USA
Tel: +1 503-228-3383
Fax: +1 503-228-5662
Email: rau@nls.com

Source: Email from Pat Rau, November 1994

PC; TrueTeX

Runs on Windows 3.1, Window NT and Windows 95.

Richard J. Kinch
TrueTeX Software
6994 Pebble Beach Court
Lake Worth FL 33467
USA
Tel: +1 561-966-8400
Fax: +1 305-644-6978
Email: kinch@truetex.com
Web: http://truetex.com/

Source: News posting from Richard Kinch, October 1997, updated from new web page.

PC; TeX

``Bitmap free TeX for Windows.''

Y&Y, Inc.
45 Walden Street
Concord MA 01742
USA
Tel: 800-742-4059 (within the USA)
Tel: +1 508-371-3286
Fax: +1 508-371-2004
Email: sales-help@YandY.com and tech-help@YandY.com
Web: http://www.YandY.com/

Source: Y&Y announcement, February 1995

pcTeX

Long-established: pcTeX32 is a Windows implementation.

Personal TeX Inc
12 Madrona Street
Mill Valley, CA 94941
USA
Tel: 800-808-7906 (within the USA)
Fax: +1 415-388-8865
Email: texsales@pctex.com and texsupp@pctex.com
Web: http://www.pctex.com/

Source: Mail from Personal TeX Inc, September 1997

PC; VTeX

DVI, PDF and HTML backends, Visual Tools and Type 1 fonts

MicroPress Inc
68-30 Harrow Street
Forest Hills, NY 11375
USA
Tel: +1 718-575-1816
Fax: +1 718-575-8038
Email: support@micropress-inc.com
Web: http://www.micropress-inc.com/

Source: Mail from MicroPress, Inc., July 1999

PC; Scientific Word

Scientific Word and Scientific Workplace offer a mechanism for near-WYSIWIG input of LaTeX documents; they ship with TrueTeX from Kinch (see above). Queries within the UK and Ireland should be addressed to Scientific Word Ltd., others should be addressed directly to the publisher, MacKichan Software Inc.

Dr Christopher Mabb
Scientific Word Ltd.
49 Queen Street
Peterhead
Aberdeenshire, AB42 1TU
UK
Tel: 0845 766 0340 (within the UK)
Tel: +44 1779 490500
Fax: 01779 490600 (within the UK)
Email: christopher@sciword.demon.co.uk
Web: http://www.sciword.demon.co.uk

MacKichan Software Inc.
600 Ericksen Ave. NE, Suite 300
Bainbridge Island WA 98110
USA
Tel: +1 206 780 2799
Fax: +1 206 780 2857
Email: info@mackichan.com
Web: http://www.mackichan.com

Source: Mail from Christopher Mabb, May 1999

Macintosh; Textures

``A TeX system `for the rest of us' ''; also gives away a Metafont implementation and some font manipulation tools.

Blue Sky Research
534 SW Third Avenue
Portland, OR 97204
USA
Tel: 800-622-8398 (within the USA)
Tel: +1 503-222-9571
Fax: +1 503-222-1643
Email: sales@bluesky.com
Web: http://www.bluesky.com/

Source: TUGboat 15(1) (1994)

AmigaTeX

A full implementation for the Commodore Amiga, including full, on-screen and printing support for all PostScript graphics and fonts, IFF raster graphics, automatic font generation, and all of the standard macros and utilities.

Radical Eye Software
PO Box 2081
Stanford, CA 94309
USA

Source: Mail from Tom Rokicki, November 1994


DVI to PostScript conversion programs

The best public domain DVI to PostScript conversion program which runs under many operating systems is Tom Rokicki's dvips. dvips is written in C and ports easily to other operating systems; it is available as dviware/dvips.tar.gz

VMS versions are available through the DECUS library (see sources of software), and also as part of the CTAN distribution of TeX for VMS (systems/OpenVMS/TEX97_CTAN.ZIP).

A precompiled version for MSDOS is available from systems/msdos/dviware/dvips.tar.gz

Karl Berry's version of dvips (called dvipsk) has a configure script and path searching code similar to that in his other programs (e.g., web2c); it is available from dviware/dvipsk.tar.gz

Another good portable program is dvitops by James Clark, which is also written in C and will compile under Unix, MSDOS, VMS, and Primos; however, it does not support virtual fonts. It is available from obsolete/dviware/dvitops.tar.gz

Macintosh users can use either the excellent drivers built into OzTeX or Textures, or a port of dvips in the CMacTeX package.


DVI drivers for HP LaserJet

The emTeX package (see TeX systems) contains a driver for the LaserJet, dvihplj.

Version 2.10 of the Beebe drivers supports the LaserJet. These drivers will compile under Unix, VMS, and on the Atari ST and DEC-20's, and are available from dviware/beebe.tar.gz

Karl Berry's dviljk, which has the same path-searching code as his dvipsk (see DVI to PostScript programs), is available in dviware/dviljk.tar.gz


DVI previewers

EmTeX for PCs running MSDOS or OS/2, MikTeX and fpTeX for PCs running Windows and OzTeX for the Macintosh, all come with previewers that can be used on those platforms. EmTeX's previewer can also be run under Windows 3.1, as can the public domain Windows previewer dviwin (dviware/dviwin.tar.gz).

Commercial PC TeX packages (see commercial vendors) have good previewers for PCs running Windows, or for Macintoshes.

For Unix systems, there is one `canonical' viewer, xdvi. The basic distribution is available as dviware/xdvi.tar.gz, and a version integrated with the current state of web2c is available from dviware/xdvik.tar.gz; Unix TeX distributions (such as teTeX or NTeX include a version of xdvik which is compatible with the version of web2c that they use.

Alternatives to previewing include

  • conversion to `similar' ASCII text (using dviware/dvi2tty.tar.gz or something of the sort) and using a conventional text viewer to look at that,

  • generating a PostScript version of your document and viewing it with a ghostscript previewer, and
  • generating PDF output, and viewing that with Acrobat Reader or one of the substitutes for that.


Fig, a TeX-friendly drawing package

(X)Fig is a menu driven tool that allows you to draw objects on the screen of an X workstation. transfig is a set of tools which translate the code fig produces to other graphics languages including PostScript and the LaTeX picture environment. They are available in graphics/xfig.tar.gz and graphics/transfig.tar.gz

Fig is supported by Micah Beck (beck@cs.cornell.edu) and transfig is maintained by Brian Smith (bvsmith@lbl.gov). Another tool for fig conversion is fig2mf which generates Metafont code from fig input. It is available in graphics/fig2mf.tar.gz


TeXCAD, a drawing package for LaTeX

TeXCAD is a program for the PC which enables the user to draw diagrams on screen using a mouse or arrow keys, with an on-screen menu of available picture-elements. Its output is code for the LaTeX picture environment. Optionally, it can be set to include lines at all angles using the emTeX driver-family \specials. TeXCAD is part of the emTeX distribution.

A Unix port of the program exists, graphics/xtexcad/xtexcad-2.4.tar.gz


Spelling checkers for work with TeX

For Unix, ispell is probably the program of choice. Browse support/ispell/ for a version, but beware of any with a number 4.x - such versions represent a divergent version of the source which lacks many useful facilities of the 3.x series.

For MSDOS, there are several programs. amspell can be called from within an editor (available as support/amspell.tar.gz). jspell is an extended version of ispell (available as support/jspell.tar.gz).

For the Macintosh, Excalibur is the program of choice. It will run in native mode on both sorts of Macintosh, and is available as systems/mac/support/excalibur/Excalibur-2.6-sit.hqx (there are other dictionaries in the same directory).

For VMS, a spell checker can be found in support/vmspell.tar.gz


What is Literate Programming?

Literate programming is the combination of documentation and source together in a fashion suited for reading by human beings. In general, literate programs combine source and documentation in a single file. Literate programming tools then parse the file to produce either readable documentation or compilable source. The WEB style of literate programming was created by D. E. Knuth during the development of his TeX typesetting software.

Discussion of literate programming is conducted in the newsgroup comp.programming.literate The literate programming FAQ is stored as help/LitProg-FAQ


WEB for C, FORTRAN, and other languages

TeX is written in the programming language WEB; WEB is a tool to implement the concept of ``literate programming''.

CWEB, a WEB for C programs, written by Silvio Levy, is available as web/c_cpp/cweb.tar.gz

Spidery WEB supports many languages including Ada, awk, and C. It was written by Norman Ramsey and, while not in the public domain, is usable free. It is available in web/spiderweb.tar.gz

FWEB is a version for Fortran, Ratfor, and C written by John Krommes. It is available in web/fweb.tar.gz

SchemeWEB is a Unix filter that translates SchemeWEB into LaTeX source or Scheme source. It was written by John Ramsdell and is available in web/schemeweb.tar.gz

APLWEB is a version of WEB for APL and is available in web/apl/aplweb.tar.gz

FunnelWeb is a version of WEB that is language independent. It is available in web/funnelweb.tar.gz

Other language independent versions of WEB are nuweb (which is written in ANSI C), available in web/nuweb.tar.gz, and noweb, available in web/noweb.tar.gz

A WEB for plain TeX macro files, using noweb, has recently been made available in web/tweb.tar.gz


Conversion between (La)TeX and others

troff

troff-to-latex (available as support/troff-to-latex.tar.gz), written by Kamal Al-Yahya at Stanford University (California, USA), assists in the translation of a troff document into LaTeX format. It recognises most -ms and -man macros, plus most eqn and some tbl preprocessor commands. Anything fancier needs to be done by hand. Two style files are provided. There is also a man page (which converts very well to LaTeX...). The program is copyrighted but free. An enhanced version of this program, tr2latex, is available in support/tr2latex.tar.gz

The DECUS TeX distribution (see sources of software) also contains a program which converts troff to TeX.

WordPerfect

wp2latex (available as support/wp2latex.tar.gz) has recently been much improved, and is now available either for MSDOS or for Unix systems, thanks to its current maintainer Jaroslav Fojtik.

PC-Write

pcwritex.arc, from support/pcwritex.tar.gz, is a print driver for PC-Write that ``prints'' a PC-Write V2.71 document to a TeX-compatible disk file. It was written by Peter Flynn at University College, Cork, Republic of Ireland.

runoff

Peter Vanroose's (vanroose@esat.kuleuven.ac.be) conversion program is written in VMS Pascal. The sources and a VAX executable are available from support/rnototex.tar.gz

refer/tib

There are a few programs for converting bibliographic data between BibTeX and refer/tib formats. They are in biblio/bibtex/utils/refer-tools.tar.gz

In spite of the directory name, it also contains a shell script to convert BibTeX to refer as well. The collection is not maintained.

RTF

A program for converting Microsoft's Rich Text Format to TeX is available in support/rtf2tex.tar.gz, which was written and is maintained by Robert Lupton (rhl@astro.princeton.edu). There is also a convertor to LaTeX by Erwin Wechtl, in support/rtf2latex.tar.gz

Translation to RTF may be done (for a somewhat constrained set of LaTeX documents) by TeX2RTF, which can produce ordinary RTF, Windows Help RTF (as well as HTML, conversion to HTML). TeX2RTF is supported on various Unix platforms and under Windows 3.1; it is available from support/tex2rtf.tar.gz

Microsoft Word

A rudimentary program for converting MS-Word to LaTeX is wd2latex, for MSDOS (dviware/wd2latex.tar.gz); a better idea, however, is to convert the document to RTF format and use one of the RTF converters mentioned above.

A FAQ that deals specifically with conversions between TeX-based formats and word processor formats is regularly posted to comp.text.tex, is available via http://www.kfa-juelich.de/isr/1/texconv/texcnv.html and is archived as help/wp-conv/wp-conv.zip

A group at Ohio State University (USA) is working on a common document format based on SGML, with the ambition that any format could be translated to or from this one. FrameMaker provides ``import filters'' to aid translation from alien formats (presumably including TeX) to Framemaker's own.


Conversion from (La)TeX to plain ASCII

The aim here is to emulate the Unix nroff, which formats text as best it can for the screen, from the same input as the Unix typesetting program troff.

Ralph Droms (droms@bucknell.edu) has a style file and a program that provide the LaTeX equivalent of nroff, though it doesn't do a good job with tables and mathematics. The software is available in support/txt.tar.gz; the original dvi2tty often does an acceptable job and is available in dviware/dvi2tty.tar.gz

Another possibility is to use screen.sty (available as macros/latex209/contrib/misc/screen.sty). Use a dvi2tty program of some kind; you might try dviware/crudetype.tar.gz as well. Another possibility is to use the LaTeX-to-ASCII conversion program, l2a (support/l2a.tar.gz), although this is really more of a de-TeXing program.

The canonical de-TeXing program is detex (support/detex.tar.gz), which removes all comments and control sequences from its input before writing it to its output. Its original purpose was to prepare input for a dumb spelling checker.


Conversion from SGML or HTML to TeX

SGML is a very important system for document storage and interchange, but it has no formatting features; its companion ISO standard DSSSL (http://www.jclark.com/dsssl/) is designed for writing transformations and formatting, but this has not yet been widely implemented. Some SGML authoring systems (e.g., SoftQuad Author/Editor) have formatting abilities, and there are high-end specialist SGML typesetting systems (e.g., Miles33's Genera). However, the majority of SGML users probably transform the source to an existing typesetting system when they want to print. TeX is a good candidate for this. There are three approaches to writing a translator:

  1. Write a free-standing translator in the traditional way, with tools like yacc and lex; this is hard, in practice, because of the complexity of SGML.

  2. Use a specialist language designed for SGML transformations; the best known are probably Omnimark and Balise. They are expensive, but powerful, incorporating SGML query and transformation abilities as well as simple translation.
  3. Build a translator on top of an existing SGML parser. By far the best-known (and free!) parser is James Clark's nsgmls, and this produces a much simpler output format, called ESIS, which can be parsed quite straightforwardly (one also has the benefit of an SGML parse against the DTD). Two good public domain packages use this method:
    • David Megginson's sgmlspm, written in Perl 5. Available from http://www.perl.com/CPAN/modules/by-module/SGMLS
    • Joachim Schrod and Christine Detig's stil, written in Common Lisp. Available from ftp://ftp.th-darmstadt.de/pub/text/sgml/stil
    Both of these allow the user to write `handlers' for every SGML element, with plenty of access to attributes, entities, and information about the context within the document tree.

    If these packages don't meet your needs for an average SGML typesetting job, you need the big commercial stuff.

Since HTML is simply an example of SGML, we do not need a specific system for HTML. However, Nathan Torkington (Nathan.Torkington@vuw.ac.nz) developed html2latex from the HTML parser in NCSA's Xmosaic package. The program takes an HTML file and generates a LaTeX file from it. The conversion code is subject to NCSA restrictions, but the whole source is available as support/html2latex.tar.gz

Michel Goossens and Janne Saarela published a very useful summary of SGML, and of public domain tools for writing and manipulating it, in TUGboat 16(2).


(La)TeX conversion to HTML

TeX is a typesetting language, not a markup system. With properly-used LaTeX, you may be luckier, but don't expect a free lunch. Remember that a) if you want a really good Web document, you had better redesign it from scratch, and b) HTML (even HTML3) has pretty poor `typesetting' facilities, and anything beyond the trivial will probably need to end up a graphic.

LaTeX2HTML (support/latex2html.tar.gz) is a package by Nikos Drakos (mostly of perl scripts) that breaks up a LaTeX document into one or more components, and links them together so that they can be read over the World-Wide Web as an hypertext document. It defines a mapping between LaTeX intra-document references and hyperlinks, and extends the mechanisms to permit reference to other (possibly remote) documents and other Internet resources. It translates LaTeX accented and other characters (as best it can) to things that World-Wide Web browsers can display, and translates mathematics (and other things that browsers can't deal with) to images that can be loaded in-line into the hypertext document.

LaTeX2HTML needs Perl, the PBM utilities, dvips, Ghostscript, and other sundries; it assumes it is running on a Unix system. Michel Goossens and Janne Saarela published a detailed discussion of LaTeX2HTML, and how to tailor it, in TUGboat 16(2).

There are two alternative strategies:

  1. Free-standing LaTeX to HTML translations. Hard, but not impossible. Julian Smart's latex2rtf (available from support/latex2rtf.tar.gz) does a plausible job on a subset of LaTeX;

  2. Writing an HTML-output backend in LaTeX itself. See Sebastian Rahtz' paper in TUGboat 16(3) for a discussion of how to go about this for the general case of SGML.


Making hypertext documents from TeX

If you want on-line hypertext with a (La)TeX source, probably on the World Wide Web, consider four technologies (which overlap):

  1. Try direct LaTeX conversion to HTML; see (La)TeX conversion to HTML;

  2. Rewrite your document using Texinfo (see Texinfo macro package), and convert that to HTML;
  3. Look at Adobe Acrobat, an electronic delivery system guaranteed to preserve your typesetting perfectly. See Making Acrobat documents from LaTeX;
  4. Invest in the hyperTeX conventions (standardised \special commands); there are supporting macro packages for plain TeX and LaTeX).

The HyperTeX project aims to extend the functionality of all the LaTeX cross-referencing commands (including the table of contents) to produce \special commands which are parsed by DVI processors conforming to the HyperTeX guidelines; it provides general hypertext links, including those to external documents.

The HyperTeX specification says that conformant viewers/translators must recognize the following set of \special commands:

href:

html:<a href = "href_string">

name:

html:<a name = "name_string">

end:

html:</a>

image:

html:<img src = "href_string">

base_name:

html:<base href = "href_string">

The href, name and end commands are used to do the basic hypertext operations of establishing links between sections of documents.

Further details are available on http://xxx.lanl.gov/hypertex/; there are two commonly-used implementations of the specification, a modified xdvi and (recent releases of) dvips. Output from the latter may be used in recent releases of Ghostscript or Acrobat Distiller.


Making Acrobat documents from LaTeX

There are three general routes to Acrobat output: Adobe's original `distillation' route (via PostScript output), conversion of an DVI file, and the use of a direct PDF generator such PDFTeX (see the PDFTeX project) or MicroPress's VTeX (see commercial TeX implementations).

For simple documents (with no hyper-references), you can either

  • process the document in the normal way, produce PostScript output and distill it,

  • (on a Windows or Macintosh machine with Acrobat Exchange installed) pass the output through the PDFwriter in place of a printer driver. This route is a dead end: the PDFwriter cannot create hyperlinks.
  • process the document in the normal way and process the DVI with dvipdfm (available from dviware/dvipdfm.tar.gz, and on the latest TeX-live disc), or
  • process the document direct to PDF with PDFTeX or VTeX. PDFTeX has the advantage of availability for a wide range of platforms, VTeX (available commercially for Windows, or free of charge for Linux - systems/linux/micropress.tar.gz) has wider graphics capability, dealing with encapsulated PostScript and some in-line PostScript.

To translate all the LaTeX cross-referencing into Acrobat links, you need a LaTeX package to suitably redefine the internal commands. There are two of these for LaTeX, both capable of conforming to the HyperTeX specification (see Making hypertext documents from TeX): Sebastian Rahtz's hyperref (available from macros/latex/contrib/supported/hyperref.tar.gz), and Michael Mehlich's hyper (available from macros/latex/contrib/supported/hyper.tar.gz). Hyperref uses a configuration file to determine how it will generate hypertext; it can operate using PDFTeX primitives, the hyperTeX \specials, or DVI driver-specific \special commands. Both dvips or Y&Y's DVIPSONE to translate the DVI into PostScript acceptable to Distiller.

There is no free implementation of all of Adobe Distiller's functionality, but Ghostscript (version 4.00 onwards) provides some restricted distilling capability (note the restrictions on the fonts it can use). However, Distiller itself is now remarkably cheap (for academics at least).

For viewing (and printing) the resulting files, Adobe's Acrobat Reader is available for a wide range of platforms (see ftp://ftp.adobe.com/pub/adobe/acrobatreader). For those platforms for which Adobe's reader is unavailable, GhostScript (versions 3.51 onwards) can display and print PDF files.


Using TeX to read SGML or XML directly

This can nowadays be done, with a certain amount of clever macro programming. David Carlisle's xmltex (macros/xmltex/base.tar.gz) and Jonathan Fine's SGMLbase (see http://www.active-tex.demon.co.uk) are two examples of packages that have been developed and are publicly available. At the time of writing, xmltex is more mature than SGMLbase, and offers a practical solution to typesetting XML files. SGMLbase is designed to cope with SGML as well as XML, but at present only has `toy' typesetting examples.

One use of a TeX that can typeset XML files is as a backend processor for XSL formatting objects, serialized as XML. Sebastian Rahtz's PassiveTeX (macros/xmltex/contrib/passivetex.tar.gz) uses xmltex to achieve this end.


Getting Metafont to do what you want

Metafont allows you to create your own fonts, and most TeX users will never need to use it. Metafont, unlike TeX, requires some customisation: each output device for which you will be generating fonts needs a mode associated with it. Modes are defined using the mode_def convention described on page 94 of The Metafontbook (see TeX-related books). You will need a file, which conventionally called local.mf, containing all the mode_defs you will be using. If local.mf doesn't already exist, Karl Berry's collection of modes, available as fonts/modes/modes.mf, is a good starting point (it can be used as a `local.mf' without modification in a `big enough' implementation of Metafont). Lists of settings for various output devices are also published periodically in TUGboat (see TUG). Now create a plain base file using inimf, plain.mf, and local.mf:

   % inimf
   This is METAFONT...
   **plain # you type plain
   (output)
   *input local # you type this
   (output)
   *dump # you type this
   Beginning to dump on file plain...
   (output)

This will create a base file named plain.base (or something similar; for example, it will be PLAIN.BAS on MSDOS systems) which should be moved to the directory containing the base files on your system (note that some systems have two or more such directories, one for each `size' of Metafont used).

Now you need to make sure Metafont loads this new base when it starts up. If Metafont loads the plain base by default on your system, then you're ready to go. Under Unix (using the default web2c ) this does indeed happen, but we could for instance define a command mf which executes virmf &plain loading the plain base file.

The usual way to create a font with plain Metafont is to start it with the line

\mode=<mode name>; mag=<magnification>; input <font file name>

in response to the `**' prompt or on the Metafont command line. (If <mode name> is unknown or omitted, the mode defaults to `proof' and Metafont will produce an output file called <font file name>.2602gf) The <magnification> is a floating point number or `magstep' (magsteps are defined in The Metafontbook and The TeXbook). If mag=<magnification> is omitted, then the default is 1 (magstep 0). For example, to generate cmr10 at 12pt for an epson printer you would type

  mf \mode=epson; mag=magstep 1; input cmr10

Note that under Unix the \ and ; characters must usually be quoted or escaped, so this would typically look something like

  mf '\mode=epson; mag=magstep 1; input cmr10'

If you don't have inimf or need a special mode that isn't in the base, you can put its commands in a file (e.g., ln03.mf) and invoke it on the fly with the \smode command. For example, to create cmr10.300gf for an LN03 printer, using the file

   % This is ln03.mf as of 1990/02/27
   % mode_def courtesy of John Sauter
   proofing:=0;
   fontmaking:=1;
   tracingtitles:=0;
   pixels_per_inch:=300;
   blacker:=0.65;
   fillin:=-0.1;
   o_correction:=.5;

(note the absence of the mode_def and enddef commands), you would type

   mf \smode="ln03"; input cmr10

This technique isn't one you should regularly use, but it may prove useful if you acquire a new printer and want to experiment with parameters, or for some other reason are regularly editing the parameters you're using. Once you've settled on an appropriate set of parameters, you should use them to rebuild the base file that you use.

A summary of the above written by Geoffrey Tobin, and tips about common pitfalls in using Metafont, is available as info/metafont-for-beginners.tex


Which font files should be kept

Metafont produces from its run three files, a metrics (TFM) file, a generic font (GF) file, and a log file; all of these files have the same base name as does the input (e.g., if the input file was cmr10.mf, the outputs will be cmr10.tfm, and cmr10.log).

For TeX to use the font, you need a TFM file, so you need to keep that. However, you are likely to generate the same font at more than one magnification, and each time you do so you'll (incidentally) generate another TFM file; these files are all the same, so you only need to keep one of them.

To preview or to produce printed output, the DVI processor will need a font raster file; this is what the GF file provides. However, while there used (once upon a time) to be DVI processors that could use GF files, modern processors use packed raster (PK) files. Therefore, you need to generate a PK file from the GF file; the program gftopk does this for you, and once you've done that you may throw the GF file away.

The log file should never need to be used, unless there was some sort of problem in the Metafont run, and need not be ordinarily kept.


Getting bitmaps from the archives

Most people these days start using TeX with a 300 dots-per-inch (dpi) laser printer, and Computer Modern bitmap fonts for this resolution are supplied with most TeX packages. There are also two such sets available on CTAN: fonts/cm/pk/pk300.zip (for write-black printer engines) and fonts/cm/pk/pk300w.zip (for write-white engines). However, some users want to send their work to high quality typesetting machines (typically with a resolution of 1270 dpi or greater); it is also becoming more common to use a 600 dpi laser printer. Why don't the archives or suppliers provide bitmap fonts at these sizes? There are two reasons:

  1. When a bitmap font is created with Metafont, it needs to know the characteristics of the device; who knows what 600 or 1270 dpi device you have? (Of course, this objection applies equally well to 300 dpi printers.)

  2. Bitmap fonts get big at high resolutions. Who knows what fonts at what sizes you need?

It would be possible to provide some set of 1270 dpi bitmap fonts in the archives, but it would take a lot of space, and might not be right for you.

So what to do? You can build the fonts you need yourself with Metafont: this isn't at all hard, and some drivers help you (dvips, and the emTeX drivers construct the Metafont commands). You might need to look at Karl Berry's collection of Metafont modes (fonts/modes/modes.mf). Alternatively, if it is a PostScript device you have, consider using the fonts in Type 1 font format. You can buy all the Computer Modern fonts in outline form from Blue Sky Research, Kinch or Y&Y (commercial vendors for addresses), or you can use Basil Malyshev's public domain versions in fonts/cm/ps-type1.tar.gz (the Paradissa collection is complete, but has largely been replaced by the better BaKoMa collection).


Using PostScript fonts with TeX

In order to use PostScript fonts, TeX needs metric (called TFM) files. Several sets of metrics are available from the archives; for mechanisms for generating new ones, see metrics for PostScript fonts. You also need the fonts themselves; PostScript printers come with a set of fonts built in, but to extend your repertoire you almost invariably need to buy from one of the many commercial font vendors (see, for example, choice of fonts).

If you use LaTeX2e, the best way to get PostScript fonts into your document is to use the PSNFSS package maintained by Sebastian Rahtz and Alan Jeffrey (available in macros/latex/required/psnfss.tar.gz); it's supported by the LaTeX3 project team, so bug reports can and should be submitted. PSNFSS gives you a set of packages for changing the default roman, sans-serif and typewriter fonts; e.g., times.sty will set up Times Roman, Helvetica and Courier in place of Computer Modern, while avant.sty just changes the sans-serif family to AvantGarde. To go with these packages, you will need the font metric files (watch out for encoding problems! see metrics for PostScript fonts) and font description (.fd) files for each font family you want to use. These can be obtained from fonts/psfonts.tar.gz, arranged by vendor (e.g., Adobe, Monotype, etc.). For convenience, metrics for the common `35' PostScript fonts found in most printers are provided with PSNFSS, packaged as macros/latex/packages/psnfss/lw35nfss.zip

For older versions of LaTeX there are various schemes, of which the simplest to use is probably the PSLaTeX macros distributed with dvips.

For plain TeX, you load whatever fonts you like; if the encoding of the fonts is not the same as Computer Modern it will be up to you to redefine various macros and accents, or you can use the font re-encoding mechanisms available in many drivers and in ps2pk and afm2tfm.

Victor Eijkhout's sophisticated Lollipop package (macros/lollipop.tar.gz) supports declaration of font families and styles in a similar way to LaTeX's NFSS, and so is easy to use with PostScript fonts.

Some common problems encountered are discussed elsewhere (see problems with PS fonts).


Previewing files using PostScript fonts

Most TeX previewers only display bitmap PK fonts. If you want to preview documents using PostScript fonts, you have three choices:

  1. Convert the DVI file to PostScript and use a PostScript previewer. Some modern Unix X implementations have this built in (as does NeXT-step); (X11) Unix, Windows, OS/2, and MSDOS users can use the free Ghostscript (support/ghostscript.tar.gz), a complete level 2 implementation.

  2. Under Windows on a PC, or on a Macintosh, let Adobe Type Manager display the fonts. Textures (Macintosh) works like this, and under Windows you can use Y&Y's dviwindo for bitmap-free previewing. (See commercial suppliers for details.)
  3. If you have the PostScript fonts in Type 1 format, use ps2pk (fonts/utilities/ps2pk.tar.gz) or gsftopk (designed for use with the Ghostscript fonts; fonts/utilities/gsftopk.tar.gz) to make PK bitmap fonts which your previewer will understand. This can produce excellent results, also suitable for printing with non-PostScript devices. Check the legalities of this if you have purchased the fonts. The very commonest PostScript fonts such as Times and Courier come in Type 1 format on disk with Adobe Type Manager (often bundled with Windows, and part of OS/2).


TeX font metric files for PostScript fonts

Font vendors such as Adobe supply metric files for each font, in AFM (Adobe Font Metric) form; these can be converted to TFM (TeX Font Metric) form. The CTAN archives have prebuilt metrics which will be more than enough for many people (fonts/psfonts.tar.gz; beware - this directory is at the root of a huge tree), but you may need to do the conversion yourself if you have special needs or acquire a new font. One important question is the encoding of (Latin character) fonts; while we all more or less agree about the position of about 96 characters in fonts (the basic ASCII set), the rest of the (typically) 256 vary. The most obvious problems are with floating accents and special characters such as the `pounds sterling' sign. There are three ways of dealing with this: either you change the TeX macros which reference the characters (not much fun, and error-prone); or you change the encoding of the font (easier than you might think); or you use virtual fonts to pretend to TeX that the encoding is the same as it is used to. If you use LaTeX2e, it allows for changing the encoding in TeX; read the LaTeX Companion (see TeX-related books) for more details. In practice, if you do much non-English (but Latin script) typesetting, you are strongly recommended to use the fontenc package with option `T1' to select T1 (`Cork') encoding.

Alan Jeffrey's fontinst package (fonts/utilities/fontinst.tar.gz) is an AFM to TFM converter written in TeX; it is used to generate the files used by LaTeX2e's PSNFSS package to support use of PostScript fonts. It is a sophisticated package, not for the faint-hearted, but is powerful enough to cope with most needs. Much of its power relies on the use of virtual fonts.

For slightly simpler problems, Rokicki's afm2tfm, distributed with dvips (dviware/dvips.tar.gz), is fast and efficient; note that the metrics and styles that come with dvips are not currently LaTeX2e compatible, but Karl Berry plans to distribute metrics directly compatible with PSNFSS in his dvipsk package.

For the Macintosh, there is a program called EdMetrics which does the job (and more). It comes with the Textures distribution, but is in fact free software, available as systems/mac/textures/utilities/EdMetrics.sea.hqx

MSDOS users can buy (see commercial implementations) Y&Y's Font Manipulation Tools package which includes a powerful afmtotfm program among many other goodies.


Problems using PostScript fonts

For the typical LaTeX user trying to use the PSNFSS package, three questions often arise. First, you have to declare to the DVI driver that you are using PostScript fonts; in the case of dvips, this means adding lines to the psfonts.map file. Otherwise, dvips will try to find PK files. If the font isn't built into the printer, you have to acquire it (in many cases this means buying it from a commercial supplier!). You then have to instruct the driver to download it with each job (the mechanism depends on your driver). So it's no good just installing the metrics for Optima and expecting it to work. You have to pay hard cash for the font itself, which will come (for Unix and MSDOS users) in pfb (Printer Font Binary) form.

Second, you cannot expect your previewer to suddenly start displaying PostScript fonts; most of them only know about PK bitmap fonts such as Computer Modern. ps2pk (fonts/utilities/ps2pk.tar.gz) can create these from the pfb file you have bought; this would also let you use the fonts with non-PostScript device drivers such as the emTeX ones. You are responsible for making sure you are not breaking the licence restrictions on font you bought.

Third, the stretch and shrink between words is a function of the font metric; it is not specified in AFM files, so different converters choose different values. The PostScript metrics that come with PSNFSS used to produce quite tight setting, but they were revised in mid 1995 to produce a compromise between American and European practice. Really sophisticated users may not find even the new the values to their taste, and want to override them. Even the casual user may find more hyphenation or overfull boxes than CMR produces; but CMR is extremely generous.


Choice of scalable outline fonts

If you are interested in text alone, you can use any of over 20,000 fonts(!) in Adobe Type 1 format (called `PostScript fonts' in the TeX world and `ATM fonts' in the DTP world), or any of several hundred fonts in TrueType format. That is, provided of course, that your previewer and printer driver support scalable outline fonts.

TeX itself only cares about metrics, not the actual character programs. You just need to create a TeX metric file TFM using some tool such as afm2tfm, afmtotfm (from Y&Y, see commercial implementations) or fontinst. For the previewer or printer driver you need the actual outline font files themselves (pfa for Display PostScript, pfb for ATM on IBM PC, Mac outline font files on Macintosh).

If you also need mathematics, then you are severely limited by the demands that TeX makes of maths fonts (for details, see the paper by B.K.P. Horn in TUGboat 14(3)). For maths, then, there are relatively few choices:

Computer Modern

(75 fonts - optical scaling) Donald E. Knuth
Note that CM is available in scalable outline form. There are commercial as well as public domain versions, and there are both Adobe Type 1 and TrueType versions. Some of these are `commercial grade,' with full hand-tuned hinting, some render very poorly, while others are merely incompatible with Adobe Type Manager (ATM).

Lucida Bright with Lucida New Math

(25 fonts) Chuck Bigelow and Kris Holmes
Lucida is a family of related fonts including seriffed, sans serif, sans serif fixed width, calligraphic, blackletter, fax, Kris Holmes' connected handwriting font, etc; they're not as `spindly' as Computer Modern, with a large x-height, and include a larger set of maths symbols, operators, relations and delimiters than CM (over 800 instead of 384: among others, it also includes the AMS msam and msbm symbol sets). The planned `Lucida Bright Expert' (14 fonts) adds seriffed fixed width, another handwriting font, smallcaps, bold maths, upright `maths italic', etc., to the set The distribution includes support for use with plain TeX and LaTeX 2.09. Support under LaTeX2e is provided in PSNFSS thanks to Sebastian Rahtz.

MathTime 1.1

(3 fonts) TeXplorators (Michael Spivak)
The set contains maths italic, symbol, and extension fonts, designed to work well with Times-Roman. These are typically used with Times, Helvetica and Courier (which are resident on many printers, and which are supplied with some PC versions). In addition you may want to complement this basic set with Adobe's Times Smallcap, and perhaps the set of Adobe `Math Pi' fonts, which include blackboard bold, blackletter, and script faces. The distribution includes support for use with plain TeX and LaTeX 2.09 (including code to link in Adobe Math Pi 2 and Math Pi 6). Support under LaTeX2e is provided in PSNFSS thanks to Sebastian Rahtz.

Adobe Lucida, LucidaSans and LucidaMath

(12 fonts)
Lucida and LucidaMath are generally considered to be a bit heavy. The three maths fonts contain only the glyphs in the CM maths italic, symbol, and extension fonts. Support for using LucidaMath with TeX is not very good; you will need to do some work reencoding fonts etc. (In some sense this set is the ancestor of the LucidaBright plus LucidaNewMath font set.)

Concrete, the AMS maths fonts etc.

Donald E. Knuth and the AMS.
These are sometimes mentioned as alternatives to CM, but they are really adjuncts, in that you need to use at least the basic CM maths fonts with them.

Proprietary fonts

Various sources.
Since having a high quality font set in scalable outline form that works with TeX can give a publisher a real competitive advantage, there are some publishers that have paid (a lot) to have such font sets made for them. Unfortunately, these sets are not available on the open market, despite the likelihood that they're more complete than those that are.

Mathptm

(4 fonts) Alan Jeffrey.
This set contains maths italic, symbol, extension, and roman virtual fonts, built from Adobe Times, Symbol, Zapf Chancery, and the Computer Modern fonts. The Mathptm fonts are free, and the resulting PostScript files can be freely exchanged. Contains most of the CM math symbols. Support under LaTeX2e in PSNFSS thanks to Alan Jeffrey and Sebastian Rahtz.

(A similar development by Walter Schmidt, using the Adobe Palatino fonts, is available from fonts/mathpple.tar.gz)

All of the first three font sets are available in formats suitable for IBM PC/Windows, Macintosh and Unix/NeXT from Y&Y and from Blue Sky Research (see commercial suppliers for details). The MathTime fonts are also available from:

TeXplorators
1572 West Gray #377
Houston TX 77019
USA

The very limited selection of maths font sets is a direct result of the fact that a maths font has to be explicitly designed for use with TeX and as a result it is likely to lose some of its appeal in other markets. Furthermore, the TeX market for commercial fonts is minute (in comparison, for example, to Microsoft TrueType font pack #1, which sold something like 10 million copies in a few weeks after release of Windows 3.1!).

Text fonts in Type 1 format are available from many vendors including Adobe, Monotype, Bitstream. Avoid cheap rip-offs: not only are you rewarding unethical behaviour, destroying the cottage industry of innovative type design, but you are also very likely to get junk. The fonts may not render well (or at all under ATM), may not have the `standard' complement of 228 glyphs, or may not include metric files (needed to make TFM files). Also, avoid TrueType fonts from all but the major vendors. TrueType fonts are an order of magnitude harder to `hint' properly than Type 1 fonts and hence TrueType fonts from places other than Microsoft and Apple may be suspect. In any case you may find other problems with TrueType fonts such as service bureaux not accepting jobs calling for them.


Including a PostScript figure in (La)TeX

LaTeX2e has a standard package for graphics inclusion, rotation, colour, and other driver-related features. The package is documented in the second edition of Lamport's LaTeX book, as well as in the LaTeX Graphics Companion (see TeX-related books).

The distribution itself comes with documentation, and a processed copy (grfguide.ps) is available in the distribution so that users can read documentation without first installing the package.

The graphics package comes with a relative, graphicx, which provides more convenient means of scaling and otherwise manipulating graphics. Both packages are configured for the particular processor you're using (either DVI processor, or PDFTeX), and the packages cope with any sort of graphics inclusion the processor understands, be it PostScript, bitmap, PDF or anything.

Both graphics and graphicx are to be found on macros/latex/required/graphics.tar.gz

If you don't use LaTeX2e, a version of the package is available that will work under Plain TeX (and other formats) - see macros/plain/graphics.tar.gz

One point to note about including PostScript figures is that they are not part of the DVI file, but are only included when you use a DVI to PostScript conversion program. The \special commands used to do this are potentially different for every DVI processor (which is why the graphics package must be configured for the processor you use). As a result, some DVI previewers will simply show the blank space TeX has reserved for your figure, not the figure itself.

There are two rather good documents on CTAN addressing figure production, with rather different emphasis. Keith Reckdahl's, info/epslatex.pdf (also available in PostScript format as info/epslatex.ps), covers the standard LaTeX facilities, as well as some of the supporting packages, notably subfigure (macros/latex/contrib/supported/subfigure.tar.gz) and psfrag (macros/latex/contrib/supported/psfrag.tar.gz). Anil K. Goel's, info/figsinltx.ps, covers the different ways in which you might generate figures, and the old (LaTeX 2.09) ways of including them into documents.


Drawing with TeX

There are many packages to do pictures in (La)TeX itself (rather than importing graphics created externally), ranging from simple use of LaTeX picture environment, through enhancements like epic, to sophisticated (but slow) drawing with PiCTeX. Depending on your type of drawing, and setup, four systems should be at the top of your list to look at:

  1. graphics/pstricks.tar.gz; this gives you access to all the power of PostScript from TeX itself, by sophisticated use of \specials. You need a decent DVI to PostScript driver (like dvips), but the results are worth it. The well-documented package gives you not only low-level drawing commands (and full colour) like lines, circles, shapes at arbitrary coordinates, but also high-level macros for framing text, drawing trees and matrices, 3D effects, and more.

  2. MetaPost; you liked Metafont, but never got to grips with font files? Try MetaPost - all the power of Metafont, but it generates PostScript figures. Knuth uses it for all his work...
  3. Mfpic; you liked Metafont, but can't understand the language? The package (graphics/mfpic.tar.gz) makes up Metafont code for you within using familiar-looking TeX macros. Not quite the full power of Metafont, but a friendlier interface.
  4. You liked PiCTeX but don't have enough memory or time? Look at Eitan Gurari's macros/generic/dratex.tar.gz, which is as powerful as most other TeX drawing packages, but is an entirely new implementation, which is not as hard on memory, is much more readable (and is fully documented).


Double-spaced documents in LaTeX

Are you producing a thesis, and trying to obey regulations that were drafted in the typewriter era? Or are you producing copy for a journal that insists on double spacing for the submitted articles?

LaTeX is a typesetting system, so the appropriate design conventions are for ``real books''. If your requirement is from thesis regulations, find whoever is responsible for the regulations, and try to get the wording changed to cater for typeset theses (e.g., to say ``if using a typesetting system, aim to make your thesis look like a well-designed book''). (If your requirement is from a journal, you're probably even less likely to be able to get the rules changed, of course.)

If you fail to convince your officials, or want some inter-line space for copy-editing:

  • Try changing \baselinestretch: \renewcommand{\baselinestretch}{1.2} may be enough to give officials the impression you've kept to their regulations. Don't try changing \baselineskip: its value is reset at any size-changing command.

  • Alternatively, use a line-spacing package. The best for current is macros/latex/contrib/supported/setspace/setspace.sty


Formatting a thesis in LaTeX

Thesis styles are usually very specific to your University, so it's usually not profitable to ask around for a package outside your own University. Since many Universities (in their eccentric way) still require double-spacing, you may care to refer to the question on double-spacing. If you want to write your own, a good place to start is the University of California style (available as macros/latex/contrib/supported/ucthesis.tar.gz), but it's not worth going to a lot of trouble. (If officials won't allow standard typographic conventions, you won't be able to produce an aesthetically pleasing document anyway!)


Flowing text around figures in LaTeX

There are several LaTeX packages that purport to do this, but they all have their limitations because the TeX machine isn't really designed to solve this sort of problem. Piet van Oostrum has conducted a survey of the available packages; he recommends:

picins

picins.sty is part of a large package (systems/msdos/picins/picins.zip) that allows inclusion of pictures (e.g., with shadow boxes, various MSDOS formats, etc.). The command is:

\parpic(width,height)(x-off,y-off)[Options][Position]{Picture}
Paragraph text

All parameters except the Picture are optional. The picture can be positioned left or right, boxed with a rectangle, oval, shadowbox, dashed box, and a caption can be given which will be included in the list of figures.

Unfortunately (for those of us whose understanding of German is not good), the documentation is in German. Piet van Oostrum has written an English summary macros/latex209/contrib/picins/picins.txt

floatflt

macros/latex/contrib/other/floatflt.tar.gz is an improved version (for LaTeX2e) of floatfig.sty, and its syntax is:

\begin{floatingfigure}[options]{width of figure}
   figure contents
\end{floatingfigure}

There is a (more or less similar) floatingtable environment.

The tables or figures can be set left or right, or alternating on even/odd pages in a double-sided document.

The package works with the multicol package, but doesn't work well in the neighbourhood of list environments (unless you change your LaTeX document).

wrapfig

macros/latex/contrib/other/misc/wrapfig.sty has syntax:

\begin{wrapfigure}[height of figure in lines]{l|r}[overhang]{width}
  figure, caption, etc.
\end{wrapfigure}

The syntax of the wraptable environment is similar.

Height can be omitted, in which case it will be calculated by the package; the package will use the greater of the specified and the actual width. The {l,r,etc.} parameter can also be specified as i(nside) or o(utside) for two-sided documents, and uppercase can be used to indicate that the picture should float. The overhang allows the figure to be moved into the margin. The figure or table will entered into the list of figures or tables if you use the \caption command.

The environments do not work within list environments that end before the figure or table has finished, but can be used in a parbox or minipage, and in twocolumn format.


Alternative head- and footlines in LaTeX

The standard LaTeX document classes define a small set of `page styles' which (in effect) specify head- and footlines for your document. The set defined is very restricted, but LaTeX is capable of much more; people occasionally set about employing LaTeX facilities to do the job, but that's quite unnecessary - Piet van Oostrum has already done the work.

The package is found in directory macros/latex/contrib/supported/fancyhdr.tar.gz and provides simple mechanisms for defining pretty much every head- or footline variation you could want; the directory also contains some (rather good) documentation and one or two smaller packages. Fancyhdr also deals with the tedious behaviour of the standard styles with initial pages, by enabling you to define different page styles for initial and for body pages.


Including a file in verbatim in LaTeX

A good way is to use Rainer Schöpf's verbatim.sty, which provides a command \verbatiminput that takes a file name as argument. This package is available as part of macros/latex/required/tools.tar.gz

Another way is to use the alltt environment, which requires alltt.sty (which is now part of LaTeX). alltt interprets its contents `mostly' verbatim, but executes any TeX commands it finds: so one can say:

  \begin{alltt}
  \input{verb.txt}
  \end{alltt}

of course, this is little use for inputting (La)TeX source code...

The moreverb package (macros/latex/contrib/supported/moreverb.tar.gz) extends the facilities of verbatim package), providing a listing environment and a \listinginput command, which line-number the text of the file.

The fancyvrb package (macros/latex/contrib/supported/fancyvrb.tar.gz) offers configurable implementations of everything verbatim and moreverb have, and more besides. It is nowadays the package of choice for the discerning typesetter of verbatim text, but its wealth of facilities makes it a complex beast and study of the documentation is strongly advised.


Including line numbers in typeset output

For general numbering of lines, there are two packages for use with LaTeX, macros/latex/contrib/supported/lineno.tar.gz (which permits labels attached to individual lines of typeset output) and macros/latex/contrib/supported/numline/numline.sty

Both of these packages play fast and loose with the LaTeX output routine, which can cause problems: the user should beware\dots

If the requirement is for numbering verbatim text, the macros/latex/contrib/supported/moreverb.tar.gz or macros/latex/contrib/supported/fancyvrb.tar.gz packages (see including files in verbatim) may be used.

One common use of line numbers is in critical editions of texts, and for this the edmac package (macros/plain/contrib/edmac.tar.gz) offers comprehensive support.


Generating an index in (La)TeX

Making an index is not trivial; what to index, and how to index it, is difficult to decide, and uniform implementation is difficult to achieve. You will need to mark all items to be indexed in your text (typically with \index commands).

It is not practical to sort a large index within TeX, so a post-processing program is used to sort the output of one TeX run, to be included into the document at the next run.

The following programs are available:

makeindex

for LaTeX under Unix (but runs under other OSs without changes). Available in indexing/makeindex.tar.gz; a version for the Macintosh is available as systems/mac/macmakeindex.sit, and one for MSDOS is part of the emTeX distribution (the emTeX version also runs under OS/2).

The Makeindex documentation is a good source of information on how to create your own index. Makeindex can be used with some TeX macro packages other than LaTeX, such as Eplain, and TeXsis, nonfree/macros/texsis.tar.gz (whose macros, nonfree/macros/texsis/index/index.tex, can be used independently with plain).

idxtex

for LaTeX under VMS. Available (together with a glossary-maker called glotex) in indexing/glo+idxtex.tar.gz

texindex

A witty little shell/sed-script-based utility for LaTeX under Unix. Available from support/texindex.tar.gz

There are other programs called texindex, notably one that comes with the Texinfo distribution.

xindy

a recent development, designed for wide-ranging flexibility (including support for multilingual indexes), based on Common Lisp. The system is available on CTAN (support/xindy.tar.gz), but is more easily accessed from a web browser via http://www.iti.informatik.th-darmstadt.de/xindy/ since the distribution contains several different implementations.


Typesetting URLs

URLs tend to be very long, and contain characters that would naturally prevent them being hyphenated even if they weren't typically set in \ttfamily, verbatim. Therefore, without special treatment, they often produce wildly overfull \hboxes, and their typeset representation is awful.

There are two approaches to this problem:

  • macros/latex/contrib/other/misc/path.sty, which defines a \path command. The command defines each potential break character as a \discretionary, and offers the user the opportunity of specifying a personal list of potential break characters. Its chief disadvantage is fragility in the LaTeX context.

  • macros/latex/contrib/other/misc/url.sty, which defines an \url command (among others, including its own \path command). The command gives each potential break character a maths-mode `personality', and then sets the URL itself in the user's choice of font, in maths mode. It can produce (LaTeX-style) `robust' commands (see use of \protect) for use within moving arguments. Note that, because the operation is conducted in maths mode, spaces within the URL argument are ignored unless special steps are taken.

The author of this answer prefers the (rather newer) url.sty; both packages work equally well with plain TeX (though of course, the fancy LaTeX facilities of url.sty don't have much place there).


Citing URLs with BibTeX

There is no citation type for URLs, per se, in the standard BibTeX styles, though Oren Patashnik (the author of BibTeX) is considering developing one such for use with the long-awaited BibTeX version 1.0.

The actual information that need be available in a citation of an URL is discussed at some length in the publicly available on-line extracts of ISO 690-2, available via http://www.nlc-bnc.ca/iso/tc46sc9/standard/690-2e.htm; the techniques below do not satisfy all the requirements of ISO 690-2, but they offer a solution that is at least available to users of today's tools.

Until the new version arrives, the simplest technique is to use the howpublished field of the standard styles' @misc function. Of course, the strictures about typesetting URLs still apply, so the entry will look like:

  @misc{...,
    ...,
    howpublished = "\url{http://...}"
  }

Another possibility is that some conventionally-published paper, technical report (or even book) is also available on the Web. In such cases, a useful technique is something like:

  @techreport{...,
    ...,
    note = "Also available as \url{http://...}"
  }

There is good reason to use macros/latex/contrib/other/misc/url.sty in this context, since (by default) it ignores spaces in its argument. BibTeX has a habit of splitting lines it considers excessively long, and if there are no space characters for it to use as `natural' breakpoints, BibTeX will insert a comment (`%') character ... which is an acceptable character in an URL, so that \url will typeset it. The way around the problem is to insert odd spaces inside the URL itself in the .bib file, to enable BibTeX to make reasonable decisions about breaking the line.


Using BibTeX with plain TeX

The file macros/eplain/btxmac.tex contains macros and documentation for using BibTeX with plain TeX, either directly or with Eplain. See the use of BibTeX for more information about BibTeX itself.


Typesetting music in TeX

A powerful package which allows the typesetting of polyphonic and other multiple-stave music is MusicTeX, written by Daniel Taupin (taupin@rsovax.lps.u-psud.fr). It is available in macros/musictex.tar.gz

In the recent past, Daniel (as well as with various other people, notably Ross Mitchell and Andreas Egler) have been working on a development of MusicTeX, known as MusiXTeX. MusiXTeX is a three-pass system (with a processor program that computes values for the element spacing in the music), and achieves finer control than is possible in the unmodified TeX-based mechanism that MusicTeX uses. Daniel Taupin and Andreas Egler are pursuing distinct versions of MusiXTeX; they are available, respectively, from macros/musixtex/taupin.tar.gz and macros/musixtex/egler.tar.gz

Digital music fans can typeset notation for their efforts by using midi2tex, which translates MIDI data files into MusicTeX source code. It is available from support/midi2tex.tar.gz

A rather simpler notation than MusicTeX is supported by abc2mtex; this is a package designed to notate tunes stored in an ASCII format (abc notation). It was designed primarily for folk and traditional tunes of Western European origin (such as Irish, English and Scottish) which can be written on one stave in standard classical notation. However, it should be extendable to many other types of music. It is available from support/abc2mtex.tar.gz

There is a mailing list for discussion of typesetting music in TeX. To subscribe, send mail to mutex-request@stolaf.edu containing the word `subscribe' in the body.


Drawing Feynman diagrams in LaTeX

Michael Levine's macro package for drawing Feynman diagrams in LaTeX is available in macros/latex209/contrib/feynman.tar.gz

Another possibility is Thorsten Ohl's macros/latex/contrib/supported/feynmf.tar.gz, that works in combination with Metafont (or MetaPost). The feynmf or feynmp package reads a description of the diagram written in TeX, and writes out code. Metafont (or MetaPost) can then produce a font (or PostScript file) for use in a subsequent LaTeX run. For new users, who have access to MetaPost, the PostScript version is probably the better route, for document portability and other reasons.


Proof environment

It is not possible to make a proof environment which automatically includes an `end-of-proof' symbol. Some proofs end in displayed maths; others do not. If the input file contains ...\] \end{proof} then LaTeX finishes off the displayed maths and gets ready for a new line before it reads any instructions connected with ending the proof. But traditionally the end-of-proof sign goes in the display, not on a new line. So you just have to put it in by hand in every proof.


Symbols for the number sets

It is a good idea to have commands such as \R for the real numbers and other standard number sets. Traditionally these were typeset in bold. Because mathematicians usually do not have access to bold chalk, they invented the special symbols that are now often used for \R, \C, etc. These symbols are known as ``blackboard bold''. Before insisting on using them, consider whether going back to the old system of ordinary bold might not be acceptable (it is certainly simpler).

A set of blackboard bold capitals is available in the AMS fonts ``msam'' (e.g., ``msam10'' for 10pt) and ``msbm''. The fonts have a large number of mathematical symbols to supplement the ones in the standard TeX distribution. The fonts are available in fonts/ams/amsfonts/sources/symbols.tar.gz

Two files which load the fonts and define the symbols are provided, and both work with either TeX or LaTeX. Questions or suggestions regarding these fonts should be directed to tech-support@math.ams.org.

Another complete set of blackboard bold fonts, the bbold family, is available in Metafont (in fonts/bbold.tar.gz). This set has the interesting property of offering blackboard bold forms of lower-case letters, something rather rarely seen on actual blackboards.

The ``lazy person's'' blackboard bold macros:

  \newcommand{\R}{{\sf R\hspace*{-0.9ex}%
    \rule{0.15ex}{1.5ex}\hspace*{0.9ex}}}
  \newcommand{\N}{{\sf N\hspace*{-1.0ex}%
    \rule{0.15ex}{1.3ex}\hspace*{1.0ex}}}
  \newcommand{\Q}{{\sf Q\hspace*{-1.1ex}%
    \rule{0.15ex}{1.5ex}\hspace*{1.1ex}}}
  \newcommand{\C}{{\sf C\hspace*{-0.9ex}%
    \rule{0.15ex}{1.3ex}\hspace*{0.9ex}}}

work well at normal size if the surrounding text is cmr10. However, they are not part of a proper maths font, and so do not work in sub- and superscripts. Moreover, the size and position of the vertical bar is affected by the font of the surrounding text.


Roman theorems

If you want to take advantage of the powerful \newtheorem command without the constraint that the contents of the theorem is in a sloped font (for example, to use it to create remarks, examples, proofs, ...) then you can use the style file theorem.sty (part of macros/latex/required/tools.tar.gz). Alternatively, the following sets up an environment remark whose content is in roman.

  \newtheorem{preremark}{Remark}
  \newenvironment{remark}%
    {\begin{preremark}\rm}{\end{preremark}}

This will not work if you are using the prototype NFSS outside of LaTeX2e, because the command \rm behaves differently there.


Fancy enumeration lists

Suppose you want your top-level enumerates to be labelled `I/', `II/', ..., then give these commands:

   \renewcommand{\theenumi}{\Roman{enumi}}
   \renewcommand{\labelenumi}{\theenumi/}

The possible styles of numbering are given in Section 6.3 of Lamport's book (see TeX-related books). Both \theenumi and \labelenumi must be changed, since \theenumi is used in cross-references to the list.

For lower level enumerates, replace enumi by enumii, enumiii or enumiv, according to the level. If your label is much larger than the default, you should also change \leftmargini, \leftmarginii, etc.

If you're running LaTeX2e, the package enumerate.sty (part of macros/latex/required/tools.tar.gz) offers similar facilities. With enumerate.sty, the example above would be achieved simply by starting the enumeration \begin{enumerate}[I/].


Unnumbered sections in the Table of Contents

The easiest way to get headings of funny `sections' such as prefaces in the table of contents is to use the counter secnumdepth described in Appendix C of the LaTeX manual. For example:

    \setcounter{secnumdepth}{-1}
    \chapter{Preface}

Of course, you have to set secnumdepth back to its usual value (which is 2 in the standard styles) before you do any `section' which you want to be numbered.

Similar settings are made automatically in the LaTeX book class by the \frontmatter and \backmatter commands.

This is why it works. \chapter without the star does

  1. put something in the .toc file;

  2. if the secnumdepth counter is greater than or equal to zero, increase the counter for the chapter and write it out.
  3. write the chapter title.

Other sectioning commands are similar, but with other values used in the test.


Footnotes in tables

The standard LaTeX \footnote command doesn't work in tables; the table traps the footnotes and they can't escape to the bottom of the page.

If your table is floating, your best bet is (unfortunately) to put the table in a minipage environment and to put the notes underneath the table, or to use Donald Arseneau's package macros/latex/contrib/other/misc/threeparttable.sty

Otherwise, if your table is not floating (it's just a `tabular' in the middle of some text), there are several things you can do to fix the problem.

  1. Use \footnotemark to position the little marker appropriately, and then put in \footnotetext commands to fill in the text once you've closed the tabular environment. This is described in Lamport's book, but it gets messy if there's more than one footnote.

  2. Stick the table in a minipage anyway. This provides all the ugliness of footnotes in a minipage with no extra effort.
  3. Use macros/latex/contrib/other/misc/threeparttable.sty anyway; the package is intended for floating tables, and the result might look odd if the table is not floating, but it will be reasonable.
  4. Use tabularx or longtable from the LaTeX tools distribution (macros/latex/required/tools.tar.gz); they're noticeably less efficient than the standard tabular environment, but they do allow footnotes.
  5. Grab hold of footnote.sty from CTAN, lurking in macros/latex/contrib/supported/mdwtools.tar.gz

    Then put your tabular environment inside a savenotes environment. Alternatively, say \makesavenoteenv{tabular} in the preamble of your document, and tables will all handle footnotes correctly.

  6. Use mdwtab.sty from the same directory (macros/latex/contrib/supported/mdwtools.tar.gz).

    This will handle footnotes properly, and has other facilities to increase the beauty of your tables. It may also cause other table-related packages (not the standard `tools' ones, though) to become very unhappy and stop working.


Style of section headings

Suppose that the editor of your favourite journal has specified that section headings must be centred, in small capitals, and subsection headings ragged right in italic, but that you don't want to get involved in the sort of programming described in The LaTeX Companion (see TeX-related books; the programming itself is discussed under `@'). The following hack will probably satisfy your editor. Define yourself new commands

  \newcommand{\ssection}[1]{%
     \section[#1]{\centering\sc #1}}
  \newcommand{\ssubsection}[1]{%
     \subsection[#1]{\raggedright\it #1}}

and then use \ssection and \ssubsection in place of \section and \subsection. This isn't perfect: section numbers remain in bold, and starred forms need a separate redefinition. Also, this will not work if you are using the prototype NFSS with LaTeX 2.09, because the font-changing commands behave differently there.

The macros/latex/contrib/supported/sectsty.tar.gz package provides an easy-to-use set of tools to do this job, while the macros/latex/contrib/supported/titlesec.tar.gz package permits more advanced usage as well. (titlesec comes with a second package, titletoc, which is used to adjust the format of table of contents entries.)

The headings of \chapter and \part commands are produced by a different mechanism; sectsty deals with both, but titlesec deals only with \chapter. The macros/latex/contrib/supported/fncychap.tar.gz package provides a nice collection of customised chapter heading designs.


Indent after section headings

LaTeX implements a style that doesn't indent the first paragraph after a section heading. There are coherent reasons for this, but not everyone likes it. The package indentfirst.sty (part of macros/latex/required/tools.tar.gz) suppresses the mechanism, so that the first paragraph is indented.


Footnotes in LaTeX section headings

The \footnote command is fragile, so that simply placing the command in \section's arguments isn't satisfactory. Using \protect\footnote isn't a good idea either: the arguments of a section command are used in the table of contents and (more dangerously) potentially also in page headings. Unfortunately, there's no mechanism to suppress the footnote in the heading while allowing it in the table of contents, though having footnotes in the table of contents is probably unsatisfactory anyway.

To suppress the footnote in headings and table of contents:

  • Take advantage of the fact that the mandatory argument doesn't `move' if the optional argument is present: \section[title]{title\footnote{title ftnt}}

  • Use the macros/latex/contrib/supported/footmisc.tar.gz package, with package option stable -this modifies footnotes so that they softly and silently vanish away if used in a moving argument.


Changing the margins in LaTeX

Don't do it. Learn some LaTeX, produce some documents, and then ask again.

You can never change the margins of a document by software, because they depend on the actual size of the paper. What you can change are the distances from the apparent top and left edges of the paper, and the width and height of the text. Changing the last two requires more skill than you might expect. The height should bear a certain relationship to \baselineskip. And the width should not be more than 75 characters. Lamport's warning in his section on `Customizing the Style' really must be taken seriously. One-inch margins on A4 paper are fine for 10- or 12-pitch typewriters, but not for 10pt type (or even 11pt or 12pt) because so many characters per line will irritate the reader. However...

Perhaps the easiest way to get more out of a page in LaTeX is to get macros/latex209/contrib/misc/fullpage.sty, which sets the margins of the page identical to those of plain TeX, i.e., 1-inch margins at all four sides of the paper. It also contains an adjustment for A4 paper.

Somewhat more flexible is macros/latex/contrib/other/misc/vmargin.sty, which has a canned set of paper sizes (a superset of that provided in LaTeX2e), provision for custom paper, margin adjustments and provision for two-sided printing.

For details of LaTeX's page parameters, see section C.5.3 of the LaTeX manual (pp. 181-182). The origin in DVI coordinates is one inch from the top of the paper and one inch from the left side; positive horizontal measurements extend right across the page, and positive vertical measurements extend down the page. Thus, for margins closer to the left and top edges of the page than 1 inch, the corresponding parameters, i.e., \evensidemargin, \oddsidemargin, \topmargin, can be set to negative values.

You cannot simply change the margins of part of a document within the document by modifying the parameters shown in Lamport's figure C.3. They should only be changed in the preamble of the document, i.e., before the \begin{document} statement. To adjust the margins within a document we define an environment:

\newenvironment{changemargin}[2]{%
 \begin{list}{}{%
  \setlength{\topsep}{0pt}%
  \setlength{\leftmargin}{#1}%
  \setlength{\rightmargin}{#2}%
  \setlength{\listparindent}{\parindent}%
  \setlength{\itemindent}{\parindent}%
  \setlength{\parsep}{\parskip}%
 }%
\item[]}{\end{list}}

This environment takes two arguments, and will indent the left and right margins by their values, respectively. Negative values will cause the margins to be narrowed, so \begin{changemargin}{-1cm}{-1cm} narrows the left and right margins by 1cm.


Finding the width of a letter, word, or phrase

Put the word in a box, and measure the width of the box. For example,

  \newdimen\stringwidth
  \setbox0=\hbox{hi}
  \stringwidth=\wd0

Note that if the quantity in the \hbox is a phrase, the actual measurement only approximates the width that the phrase will occupy in running text, since the inter-word glue can be adjusted in paragraph mode.

The same sort of thing is expressed in LaTeX by:

  \newlength{\gnat}
  \settowidth{\gnat}{\textbf{small}}

This sets the value of the length command \gnat to the width of ``small'' in bold-face text.


Changing the space between letters

A common technique in advertising copy (and other text whose actual content need not actually be read) is to alter the space between the letters (otherwise known as the tracking). As a general rule, this is a very bad idea: it detracts from legibility, which is contrary to the principles of typesetting (any respectable font you might be using should already have optimum tracking built into it).

The great type designer, Eric Gill, is (possibly apocryphally) credited with saying ``he who would letterspace lower-case text, would steal sheep'' (stealing sheep was, before Gill's time, a capital offence in Britain). As the remark suggests, though, letterspacing of upper-case text is less awful a crime; the technique used also to be used for emphasis of text set in gothic (or similar) fonts.

Straightforward macros (usable, in principle, with any TeX macro package) may be found in macros/generic/letterspacing.tex

A more comprehensive package is macros/latex/contrib/supported/soul.tar.gz (which is optimised for use with LaTeX, but also works with Plain TeX. Soul also permits hyphenation of letterspaced text; Gill's view of such an activity is not (even apocryphally) recorded.


Excluding blocks of text from the DVI file

Rainer Schöpf's verbatim.sty provides a comment environment which excludes everything between \begin{comment} and \end{comment}. This package is available as part of macros/latex/required/tools.tar.gz

A more general environment for doing the job is Victor Eijkhout's comment.sty, which lets you define environments for inclusion or exclusion in a document, thus offering a primitive configuration structure. It is available from the CTAN sites in macros/latex209/contrib/misc/comment.sty


Setting bold Greek letters in LaTeX

The simple solution (\mathbf) doesn't always work, because lower-case Greek letters behave differently from upper-case Greek letters (due to Knuth's esoteric font encoding decisions). However, \mathbf can be used for upper-case Greek letters in ordinary circumstances, but the AMSLaTeX package amsmath.sty disables this font-switching and you must use one of the techniques outlined below.

The plain TeX solution does work, in a limited way:

  {\boldmath$\theta$}

but \boldmath may not be used in maths mode, so this `solution' requires arcana such as:

  $... \mbox{\boldmath$\theta$} ...$

which then causes problems in superscripts, etc.

These problems may be addressed by using a bold mathematics package.

  • The package bm.sty, which is part of the LaTeX tools distribution (macros/latex/required/tools.tar.gz), defines a command \bm which may be used anywhere in maths mode.

  • The package amsbsy.sty, which is part of AMSLaTeX (macros/latex/required/amslatex.tar.gz) defines a command \boldsymbol, which (though slightly less comprehensive than \bm) covers almost all common cases.

All these solutions cover all mathematical symbols, not merely Greek letters.


Defining a new log-like function in LaTeX

Use the \mathop command, as in:

\newcommand{\diag}{\mathop{\rm diag}}

Subscripts and superscripts on \diag will be placed exactly as they are on \lim. If you want your subscripts and superscripts always placed to the right, do:

\newcommand{\diag}{\mathop{\rm diag}\nolimits}

This works in LaTeX 2.09 and in LaTeX2e, but not under NFSS alone (see problems with \rm, etc.). However, the canonical method for doing this in LaTeX2e is to use the the \DeclareMathOperator command of amsopn.sty (which is part of the AMSLaTeX package: macros/latex/required/amslatex.tar.gz).

(It should be noted that ``log-like'' was reportedly a joke on Lamport's part; it is of course clear what was meant.)


Typesetting all those TeX-related logos

Knuth was making a particular point about the capabilities of TeX when he defined the logo. Unfortunately, many believe, he thereby opened floodgates to give the world a whole range of rather silly `bumpy road' logos such as AMSTeX, PiCTeX, BibTeX, and so on, produced in a flurry of different fonts, sizes, and baselines - indeed, everything one might hope to cause them to obstruct the reading process. In articular, Lamport invented LaTeX (silly enough in itself, with a raised small `A' and a lowered `E') and marketing input from Addison-Wesley led to the even stranger current logo LaTeX2e, which appends a lowered single-stroke greek letter epsilon.

Sensible users don't have to follow this stuff wherever it goes, but, for those who insist, a large collection of logos is defined in macros/eplain/texnames.sty (but note that this set of macros isn't entirely reliable in LaTeX2e). The Metafont and MetaPost logos can be set in fonts that LaTeX2e knows about (so that they scale with the surrounding text) using the package macros/latex/contrib/supported/mflogo.tar.gz; but be aware that booby-traps surround the use of the Knuthian font for MetaPost (you might get something like `META&nbsp;O&nbsp;T'). You needn't despair, however - the author himself uses just `MetaPost'.

For those who don't wish to acquire the `proper' logos, the canonical thing to do is to say AMS-\TeX{} for AMSTeX, Pic\TeX{} for PiCTeX, Bib\TeX{} for BibTeX, and so on.

While the author of this FAQ list can't quite bring himself to do away with the bumpy-road logos herein, he regularly advises everyone else to\dots


1-column abstract in 2-column document

One often requires that the abstract of a paper should appear across the entire page, even in a two-column paper. The required trick is:

  \documentclass[twocolumn]{article}
  ...
  \begin{document}
  ... % \author, etc
  \twocolumn[
    \begin{@twocolumnfalse}
      \maketitle
      \begin{abstract}
        ...
      \end{abstract}
    \end{@twocolumnfalse}
  ]

Unfortunately, with the above \thanks won't work in the \author list. If you need such specially-numbered footnotes, you can make them like this:

  \title{Demonstration}
  \author{Me, You\thanks{}}
  \twocolumn[
    ... as above ...
  ]
  {
    \renewcommand{\thefootnote}%
      {\fnsymbol{footnote}}
    \footnotetext[1]{Thanks for nothing}
  }

and so on.


Changing babel's ideas of words to use

LaTeX uses symbolic names for many of the automatically-generated text it produces (special-purpose section headers, captions, etc.). For example, the special section produced by the \tableofcontents command is always called \contentsname (or rather, what \contentsname is set to).

When babel is selecting a new language, it ensures that these symbolic names are translated appropriately for the language in question. In particular, babel selects the document's main language at the point that \begin{document} is executed, which means that any changes to these symbolic names made in the prologue of a document that uses babel will be lost.

Therefore, babel defines a command to enable users to change the definitions of the symbolic names, on a per-language basis: \addto\captions<language> is the thing.

For example:

\addto\captionsdanish{%
  \renewcommand{\contentsname}%
    {Indholdsfortegnelse}%
}


Code listings in LaTeX

`Pretty' code listings are sometimes considered worthwhile by the neurotically aesthetic programmer, but they have a serious place in the typesetting of dissertations by computer science and other students who are expected to write programs. Simple verbatim listings are commonly useful, as well.

Verbatim listings are dealt with elsewhere (see including files in verbatim). `Pretty' listings are generally provided by means of a pre-compiler, but the listings package (macros/latex/contrib/supported/listings.tar.gz) manages to do the job within LaTeX.

The lgrind system (CTAN support/lgrind.tar.gz) is a well-established pre-compiler, with all the facilities one might need and a wide repertoire of languages.

The tiny_c2l system (CTAN support/tiny_c2l.tar.gz) is more recent: users are encouraged to generate their own driver files for languages it doesn't already deal with.


Setting papers for journals

Publishers of journals have a wide range of requirements for the presentation of papers, and while many publishers do accept electronic submissions in (La)TeX, they don't often submit recommended macros to public archives.

Nevertheless, there are considerable numbers of macros of one sort or another available on CTAN; searching for your journal name in the CTAN catalogue (http://www.tex.ac.uk/tex-archive/help/Catalogue/catalogue.html) may well turn up what you're seeking.

Failing that, you may be well advised to contact the prospective publisher of your paper; many publishers have macros on their own web sites, or otherwise available only upon application.

Check that the publisher is offering you macros suitable to an environment you can use: a few still have no macros for current LaTeX, for example, claiming that LaTeX 2.09 is good enough\dots

Some publishers rekey anything sent them anyway, so that it doesn't really matter what macros you use. Others merely encourage you to use as few extensions of a standard package as possible, so that they will find it easy to transform your paper to their own internal form.


A `report' from lots of `article's

This is a requirement, for example, if one is preparing the proceedings of a conference whose papers were submitted in LaTeX.

There's no canned solution, but Matt Swift's includex and moredefs packages (both part of the macros/latex/contrib/supported/frankenstein.tar.gz bundle) offer a possible way forward.

includex enables you to `\includedoc' complete articles (in the way that you `\include' chapter files in an ordinary report). It doesn't do the whole job for you, though. You need to analyse the package use of the individual papers, and ensure that a consistent set is loaded in the preamble of the main report.

Another tedious problem to address is that LaTeX suppresses all title-related commands after \maketitle has been used once in a document: thus you need to define replacements for all of them, for use in the papers.

More work is plainly needed in this area, but at least a start has been made.


Curriculum Vitae (Resumé)

A framework class for Curricula Vitae, provided by Andrej Brodnik, is available from macros/latex/contrib/other/vita.tar.gz

The class can be customised both for subject (example class option files are offered for both computer scientists and singers), and for language (both the options provided are available for both English and Slovene). Extensions may be written by creating new class option files, or by using macros defined in the class to define new entry types, etc.


Weird hyphenation of words

You may have a version mismatch problem. TeX's hyphenation system changed between version 2.9 and 3.0. If you are using (plain) TeX version 3.0 or later, make sure your plain.tex file has a version number which is at least 3.0. If you are using LaTeX 2.09 you should consider upgrading to LaTeX2e; if for some reason you can't, the last version of LaTeX 2.09, released on 25 March 1992, is available (for the time being at least) from obsolete/macros/latex209/distribs/latex209.tar and ought to solve this problem.

If you're using LaTeX2e, the problem probably arises from your hyphen.cfg file, which has to be created if you're using a multi-lingual version.

For the curious, here's what happened: before TeX 3.0 the hyphenation algorithm would not break a word if the part before the break was not at least two characters long, and the part after the break at least three characters long. Starting with version 3.0 the parameters \lefthyphenmin and \righthyphenmin control the length of these fragments. These are set to 2 and 3, respectively, in the new plain and lplain formats. They can be set to any value, of course, but if \lefthyphenmin+\righthyphenmin is greater than 62, all hyphenation is suppressed.

A further source of oddity can derive from the 1995 release of Cork-encoded fonts, which introduced an alternative hyphen character. The LaTeX2e configuration files in the font release specified use of the alternative hyphen, and this could produce odd effects with words containing an explicit hyphen. The font configuration files in the December 1995 release of LaTeX2e do not use the alternative hyphen character, thus removing this source of problems.


(Merely) peculiar hyphenation

You may have found that TeX's famed automatic word-division does not produce the break-points recommended by your dictionary. This may be because TeX is set up for American English, whose rules for word division (as specified, for example, in Webster's Dictionary) are completely different from the British ones (as specified, for example, in the Oxford Dictionaries). This problem is being addressed by the UK TeX User community (see Baskerville, issue 4.4) but an entirely satisfactory solution will take time. An interim hyphenation file is available in language/hyphenation/ukhyphen.tex


Accented words aren't hyphenated

TeX's algorithm for hyphenation gives up when it encounters an \accent command; there are good reasons for this, but it means that quality typesetting in non-English languages can be difficult.

For TeX itself, avoiding this effect means using Cork-encoded fonts (the EC fonts) which contain accented letters as single glyphs. In the future, perhaps, Omega will provide a rather different solution.


Enlarging TeX

The TeX error message `capacity exceeded' covers a multitude of problems. What has been exhausted is listed in brackets after the error message itself, as in:

  ! TeX capacity exceeded, sorry
..               [main memory size=263001].

Most of the time this error can be fixed without enlarging TeX. The most common causes are unmatched braces, extra-long lines, and poorly-written macros. Extra-long lines are often introduced when files are transferred incorrectly between operating systems, and line-endings are not preserved properly (the tell-tale sign of an extra-long line error is the complaint that the `buf_size' has overflowed).

If you really need to extend your TeX's capacity, the proper method depends on your installation. There is no need (with modern TeX implementations) to change the defaults in Knuth's WEB source; but if you do need to do so, use a change file to modify the values set in module 11, recompile your TeX and regenerate all format files.

Modern implementations allow the sizes of the various bits of TeX's memory to be changed semi-dynamically. Some (such as emTeX) allow the memory parameters to be changed in command-line switches when TeX is started; most frequently, a configuration file is read which specifies the size of the memory. On web2c-based systems, this file is called texmf.cnf: see the documentation that comes with the distribution for other implementations. Again, in many cases, the format files need to be regenerated after changing the memory parameters.


Moving tables and figures in LaTeX

Tables and figures have a tendency to surprise, by floating away from where they were specified to appear. This is in fact perfectly ordinary document design; any professional typesetting package will float figures and tables to where they'll fit without violating the certain typographic rules. Even if you use the placement specifier h for `here', the figure or table will not be printed `here' if doing so would break the rules; the rules themselves are pretty simple, and are given on page 198, section C.9 of the LaTeX manual. In the worst case, LaTeX's rules can cause the floating items to pile up to the extent that you get an error message saying ``Too many unprocessed floats''; this means that the limited set of registers in which LaTeX stores floating items is full. What follows is a simple checklist of things to do to solve these problems (the checklist talks throughout about figures, but applies equally well to tables).

  • Are the placement parameters on your figures right? The default (tbp) is reasonable; you should never simply say `h', for example, since that says ``if it can't go here, it can't go anywhere'', and as a result all subsequent floats pile up behind it.

  • Can you perhaps prevent your figures from floating by adjusting LaTeX's placement parameters? Again, the defaults are reasonable, but can be overridden in case of problems. The parameters are described on pages 199-200, section C.9 of the LaTeX manual.
  • Are there places in your document where you could `naturally' put a \clearpage command? If so, do: the backlog of floats is cleared after a \clearpage. (Note that the \chapter command implicitly executes \clearpage, so you can't float past the end of a chapter.)
  • Have a look at the LaTeX2e afterpage package (part of macros/latex/required/tools.tar.gz). Its documentation gives as an example the idea of putting \clearpage after the current page (where it will clear the backlog, but not cause an ugly gap in your text), but also admits that the package is somewhat fragile (though it's improving).
  • As a last resort, try the package macros/latex209/contrib/misc/morefloats.sty; this `simply' increases the number of floating inserts that LaTeX can handle at one time (from 18 to 36), but that may suit your needs.
  • If you actually wanted all your figures to float to the end (e.g., for submitting a draft copy of a paper), don't rely on LaTeX's mechanism: get the package macros/latex/contrib/supported/endfloat.tar.gz to do the job for you.


\pagestyle{empty} on first page in LaTeX

If you use \pagestyle{empty}, but the first page is numbered anyway, you are probably using the \maketitle command too. This is not a bug but a feature! The standard LaTeX styles are written so that initial pages (pages containing a \maketitle, \part, or \chapter) have a different page style from the rest of the document; Hence, the commands internally issue \thispagestyle{plain}. This is usually not acceptable behaviour if the surrounding page style is `empty'.

Possible workarounds include:

  • Put \thispagestyle{empty} immediately after the \maketitle command, with no blank line between them.

  • Use fancyhdr.sty, which allows you to customise the style for initial pages independently of that for body pages. It is available in macros/latex/contrib/supported/fancyhdr.tar.gz
  • Use nopageno.sty, which suppresses this behaviour. It is available in macros/latex/contrib/supported/carlisle/nopageno.sty


Underlined text won't break

Knuth made no provision for underlining text: he took the view that underlining is not a typesetting operation, but rather one that provides emphasis on typewriters, which typically offer but one typeface. The corresponding technique in typeset text is to switch from upright to italic text (or vice-versa): the LaTeX command \emph does just that to its argument.

Nevertheless, typographically illiterate people (such as those that specify double-spaced thesis styles) continue to require underlining of us, so LaTeX as distributed defines an \underline command that applies the mathematical `underbar' operation to text. This technique is not entirely satisfactory, however: the text gets stuck into a box, and won't break at line end.

The solution is the package macros/latex/contrib/other/misc/ulem.sty, which redefines the \emph command to underline its argument; the underlined text thus produced behaves as ordinary emphasised text, and will break over the end of a line. (The package is capable of other peculiar effects, too: read its documentation, contained within the file itself.)


Odd behaviour of \rm, \bf, etc.

If commands such as \rm and \bf have suddenly stopped working in LaTeX in the way that you expect, it is likely that your system administrator has installed a version of LaTeX 2.09 with a prototype version of the NFSS (now part of LaTeX2e). Complain loudly; ask your system administrator to replace this version with LaTeX2e, in which commands such as \rm and \bf work just as before if you are using one of the standard classes -article, report and book (among others). In the meantime, use the option oldlfont.sty, which should have been installed at the same time as NFSS.


Old LaTeX font references such as \tenrm

LaTeX 2.09 defined a large set of commands for access to the fonts that it had built in to itself. For example, various flavours of cmr could be found as \fivrm, \sixrm, \sevrm, \egtrm, \ninrm, \tenrm, \elvrm, \twlrm, \frtnrm, \svtnrm, \twtyrm and \twfvrm. These commands were never documented, but certain packages nevertheless used them to achieve effects they needed.

Since the commands weren't public, they weren't included in LaTeX2e; to use the unconverted LaTeX 2.09 packages under LaTeX2e, you need also to include the package rawfonts.sty (which is part of the LaTeX2e distribution).


Missing symbols

If some symbols, such as \Box and \lhd, no longer appear to exist, then your system administrator has probably upgraded your version of LaTeX to either use the prototype NFSS or LaTeX2e. In the former case, use oldlfont.sty (see problems with \rm, etc.). In the latter, use the package latexsym, which is part of the LaTeX2e distribution, or the package amsfonts, if it is available.


LaTeX gets cross-references wrong

Sometimes, however many times you run LaTeX, the cross-references are just wrong. Remember that the \label command must come after the \caption command, or be part of it. For example,

\begin{figure}          \begin{figure}
\caption{A Figure}  or  \caption{A Figure%
\label{fig}                   \label{fig}}
\end{figure}            \end{figure}


\@ and @ in macro names

A common source of problems in a LaTeX document is the diagnostic about the appearance of the command \@, or about other commands containing the character @. The most common complaint is ``You can't use `\spacefactor' in vertical mode'', but others occur.

Such problems are usually caused by including a LaTeX2e class or package file into a LaTeX document by some means other than \documentclass or \usepackage. LaTeX defines internal commands whose names contain the character @; this enables it to avoid clashes between its internal names and names that we would normally use in our documents. In order that these commands may work at all, \documentclass and \usepackage play around with the meaning of @. Solve this problem by using the correct command to include the file.

But, you will say, ``The LaTeX Companion tells me to use commands containing @!''

Indeed; for example, there's a lengthy section about \@startsection and how to use it to control the appearance of section titles. Page 15 of The Companion explains this; and suggests that you make such changes in the document preamble, between \makeatletter and \makeatother. So the definition of \subsection on page 26 could be:

  \makeatletter
  \renewcommand{\subsection}{\@startsection
    {subsection}%                    % name
    ...
    {\normalfont\normalsize\itshape}}% style
  \makeatother


Where are the msx and msy fonts?

The msx and msy fonts were designed by the American Mathematical Society in the very early days of TeX, for use in typesetting papers for mathematical journals. They were designed using the `old' Metafont, which wasn't portable and is no longer available; for a long time they were only available in 300dpi versions which only imperfectly matched modern printers. The AMS has now redesigned the fonts, using the current version of Metafont, and the new versions are called the msa and msb families; they are available from fonts/ams/amsfonts/sources/symbols.tar.gz

Nevertheless, msx and msy continue to turn up to plague us. There are, of course, still sites that haven't got around to upgrading; but, even if everyone upgraded, there would still be the problem of old documents that specify them.

If you have a .tex source that requests msx and msy, the best technique is to edit it so that it requests msa and msb (you only need to change the single letter in the font names).

If you have a DVI file that requests the fonts, there is a package of virtual fonts to map the old to the new series; it's available in fonts/vf-files/msx2msa.tar.gz


Where are the am fonts?

One still occasionally comes across a request for the am series of fonts. The initials stood for `Almost [Computer] Modern', and they were the predecessors of the Computer Modern fonts that we . There's not a lot one can do with these fonts; they are (as their name implies) almost (but not quite) the same as the cm series; if you're faced with a document that requests them, all you can reasonably do is to edit the document. The appearance of DVI files that request them is sufficiently rare that no-one has undertaken the mammoth task of creating a translation of them by means of virtual fonts; however, most drivers let you have a configuration file in which you can specify font substitutions. If you specify that every am font should be replaced by its corresponding cm font, the output should be almost correct.


`String too long' in BibTeX

The BibTeX diagnostic ``Warning-you've exceeded 1000, the global-string-size, for entry foo'' usually arises from a very large abstract or annotation included in the database. The diagnostic usually arises because of an infelicity in the coding of abstract.bst, or styles derived from it. (One doesn't ordinarily output annotations in other styles.)

The solution is to make a copy of the style file (or get a clean copy from CTAN - biblio/bibtex/contrib/abstract.bst), and rename it (e.g., on a long file-name system to abstract-long.bst). Now edit it: find function output.nonnull and

  • change its first line (line 60 in the version on CTAN) from "{ 's :=" to "{ swap$", and

  • delete its last line, which just says "s" (line 84 in the version on CTAN).

Finally, change your \bibliographystyle command to refer to the name of the new file.

This technique applies equally to any bibliography style: the same change can be made to any similar output.nonnull function.

If you're reluctant to make this sort of change, the only way forward is to take the entry out of the database, so that you don't encounter BibTeX's limit, but you may need to retain the entry because it will be included in the typeset document. In such cases, put the body of the entry in a separate file:

  @article{long.boring,
    author =    "Fred Verbose",
    ...
    abstract =  "{\input{abstracts/long.tex}}"
  }

In this way, you arrange that all BibTeX has to deal with is the file name, though it will tell TeX (when appropriate) to include all the long text.


What's going on in my \include commands?

The original LaTeX provided the \include command to address the problem of long documents: with the relatively slow computers of the time, the companion \includeonly facility was a boon. With the vast increase in computer speed, \includeonly is less valuable (though it still has its place in some very large projects). Nevertheless, the facility is retained in current LaTeX, and causes some confusion to those who misunderstand it.

In order for \includeonly to work, \include makes a separate .aux file for each included file, and makes a `checkpoint' of important parameters (such as page, figure, table and footnote numbers); as a direct result, it must clear the current page both before and after the \include command. What's more, this mechanism doesn't work if a \include command appears in a file that was \included itself: LaTeX diagnoses this as an error.

So, we can now answer the two commonest questions about \include:

  • Why does LaTeX throw a page before and after \include commands?

    Answer: because it has to. If you don't like it, replace the \include command with \input - you won't be able to use \includeonly any more, but you probably don't need it anyway, so don't worry.

  • Why can't I nest \included files? - I always used to be able to under LaTeX 2.09.

    Answer: in fact, you couldn't, even under LaTeX 2.09, but the failure wasn't diagnosed. However, since you were happy with the behaviour under LaTeX 2.09, replace the \include commands with \input commands (with \clearpage as appropriate).


Why does it ignore paragraph parameters?

When TeX is laying out text, it doesn't work from word to word, or from line to line; the smallest complete unit it formats is the paragraph. The paragraph is laid down in a buffer, as it appears, and isn't touched further until the end-paragraph marker is processed. It's at this point that the paragraph parameters have effect; and it's because of this sequence that one often makes mistakes that lead to the paragraph parameters not doing what one would have hoped (or expected).

Consider the following sequence of LaTeX:

  {\raggedright % declaration for ragged text
  Here's text to be ranged left in our output,
  but it's the only such paragraph, so we now
  end the group.}

  Here's more that needn't be ragged...

TeX will open a group, and set the ragged-setting parameters within that group; it will then save a couple of sentences of text and close the group (thus restoring the previous value of the ragged-setting parameters). Then it encounters a blank line, which it knows to treat as a \par token, so it typesets the two sentences; but because the enclosing group has now been closed, the parameter settings have been lost, and the paragraph will be typeset normally.

The solution is simple: close the paragraph inside the group, so that the setting parameters remain in place. An appropriate way of doing that is to replace the last three lines above with:

  end the group.\par}
  Here's more that needn't be ragged...

In this way, the paragraph is completed while the setting parameters are still in force within the enclosing group.

Another alternative is to define an environment that does the appropriate job for you. For the above example, LaTeX already defines an appropriate one:

\begin{flushleft}
  Here's text to be ranged left...
\end{flushleft}


What's the reason for `protection'?

Sometimes LaTeX saves data it will reread later. These data are often the argument of some command; they are the so-called moving arguments. (`Moving' because data are moved around.) Places to look for are all arguments that may go into table of contents, list of figures, etc.; namely, data that are written to an auxiliary file and read in later. Other places are those data that might appear in head- or footlines. Section headers and figure captions are the most prominent examples; there's a complete list in Lamport's book (see TeX-related books).

What's going on really, behind the scenes? The commands in the moving arguments are already expanded to their internal structure during the process of saving. Sometimes this expansion results in invalid TeX code when processed again. ``\protect\cmd'' tells LaTeX to save \cmd as \cmd, without expansion.

What is a `fragile command'? It's a command that expands into illegal TeX code during the save process.

What is a `robust command'? It's a command that expands into legal TeX code during the save process.

No-one (of course) likes this situation; the LaTeX3 team have removed the need for protection of some things in the production of LaTeX2e, but the techniques available to them within current LaTeX mean that this is an expensive exercise. It remains a long-term aim of the team to remove all need for these things.


Why doesn't \verb work within...?

The LaTeX verbatim commands work by changing category codes. Knuth says of this sort of thing ``Some care is needed to get the timing right...'', since once the category code has been assigned to a character, it doesn't change. So \verb has to assume that it is getting the first look at its parameter text; if it isn't, TeX has already assigned category codes so that \verb doesn't have a chance. For example:

    \verb+\error+

will work (typesetting `\error'), but

    \newcommand{\unbrace}[1]{#1}
    \unbrace{\verb+\error+}

will not (it will attempt to execute \error). Other errors one may encounter are `\verb ended by end of line', or even `\verb illegal in command argument'.

This is why the LaTeX book insists that verbatim commands must not appear in the argument of any other command; they aren't just fragile, they're quite unusable in any command parameter, regardless of \protection.


Case-changing oddities

TeX provides two primitive commands \uppercase and \lowercase to change the case of text; they're not much used, but are capable creating confusion.

The two commands do not expand the text that is their parameter - the result of \uppercase{abc} is `ABC', but \uppercase{\abc} is always `\abc', whatever the meaning of \abc. The commands are simply interpreting a table of equivalences between upper- and lowercase characters. They have (for example) no mathematical sense, and

  \uppercase{About $y=f(x)$}

will produce

  ABOUT $Y=F(X)$

which is probably not what is wanted.

In addition, \uppercase and \lowercase do not deal very well with non-American characters, for example \uppercase{\ae} is the same as \ae.

LaTeX provides commands \MakeUppercase and \MakeLowercase which fixes the latter problem. These commands are used in the standard classes to produce upper case running heads for chapters and sections.

Unfortunately \MakeUppercase and \MakeLowercase do not solve the other problems with \uppercase, so for example a section title containing \begin{tabular} ... \end{tabular} will produce a running head containing \begin{TABULAR}. The simplest solution to this problem is using a user-defined command, for example:

   \newcommand{\mytable}{\begin{tabular}...
      \end{tabular}}
   \section{A section title \protect\mytable{}
       with a table}

Note that \mytable has to be protected, otherwise it will be expanded and made upper case.


Why are # signs doubled in macros?

The way to think of this is that ## gets replaced by # in just the same way that #1 gets replaced by `whatever is the first argument'.

So if you define a macro and use it as:

  \def\a#1{+++#1+++#1+++#1+++}  \a{b}

the macro expansion produces `+++b+++b+++b+++', which people find normal. However, if we now replace part of the macro:

  \def\a#1{+++#1+++\def\x #1{xxx#1}}

\a{b} will expand to `+++b+++\def\x b{xxxb}'. This defines \x to be a macro delimited by b, and taking no arguments, which people may find strange, even though it is just a specialisation of the example above. If you want \a to define \x to be a macro with one argument, you need to write:

  \def\a#1{+++#1+++\def\x ##1{xxx##1}}

and \a{b} will expand to `+++b+++\def\x #1{xxx#1}', because #1 gets replaced by `b' and ## gets replaced by #.

To nest a definition inside a definition inside a definition then you need ####1, as at each stage ## is replaced by #. At the next level you need 8 #s each time, and so on.


Why does LaTeX split footnotes across pages?

LaTeX splits footnotes when it can think of nothing better to do. Typically, when this happens, the footnote mark is at the bottom of the page, and the complete footnote would overfill the page. LaTeX could try to salvage this problem by making the page short of both the footnote and the line with the footnote mark, but its priorities told it that splitting the footnote would be preferable.

As always, the best solution is to change your text so that the problem doesn't occur in the first place. Consider whether the text that bears the footnote could move earlier in the current page, or on to the next page.

If this isn't possible, you might want to change LaTeX's perception of its priorities: they're controlled by \interfootnotelinepenalty - the larger it is, the less willing LaTeX is to split footnotes.

Setting

  \interfootnotelinepenalty=10000

inhibits split footnotes altogether, which will cause `Underfull \vbox' messages unless you also specify \raggedbottom. The default value of the penalty is 100, which is rather mild.

An alternative technique is to juggle with the actual size of the pages. \enlargethispage changes the size of the current page by its argument (for example, you might say \enlargethispage{\baselineskip} to add a single line to the page, but you can use any ordinary TeX length such as 15mm or -20pt as argument). Reducing the size of the current page could force the offending text to the next page; increasing the size of the page may allow the footnote to be included in its entirety. It may be necessary to change the size of more than one page.


Getting \marginpar on the right side

In twoside documents, LaTeX makes stirling attempts to put \marginpars in the correct margin (the outer or the gutter margin, according to the user's command). However, a booby-trap arises because TeX runs its page maker asynchronously. If a \marginpar is processed while page n is being being built, but doesn't get used until page n+1, then the \marginpar will turn up on the wrong side of the page.

The solution to the problem is for LaTeX to `remember' which side of the page each \marginpar should be on. The package macros/latex/contrib/supported/mparhack.tar.gz does this, using marks stored in the .aux file.


Why does PiCTeX run out of `\dimen's?

PiCTeX uses a lot of TeX's counter and length registers. Since TeX only has 256 of each, it's therefore often impossible to load PiCTeX.

The ConTeXt modules m-pictex.tex (for plain TeX and variants) or m-pictex.sty (for LaTeX; both files are available from macros/context/cont-tmf.zip). m-pictex.tex provides an ingenious solution to the problem based on hacking the code of \newdimen itself.

An alternative is Andreas Schrell's pictexwd packages (from graphics/pictex/addon.tar.gz, which replaces PiCTeX itself and simply uses less registers.


Why won't LaTeX `fixed' names stay changed?

LaTeX has many commands that define the names that are used for common functions in document - for example, \chaptername, \figurename, and so on. These names allow users to adjust the appearance of their documents, most notably when the document itself is being written in a language other than LaTeX's default English.

The babel package, of course, uses this mechanism extensively, setting up a new set of names whenever the user declares that the current language is changing. However, babel's defaults are not to everyone's liking, so users often want to change names after they've loaded babel.

The simplest approach:

  \usepackage[frenchb]{babel}
  \renewcommand{\refname}{Bibliographie}

doesn't work: babel actually performs its \selectlanguage operation at the start of the document, and so the \renewcommand is lost. For a single-language document, the sequence:

  \usepackage[frenchb]{babel}
  \AtBeginDocument{%
    \renewcommand{\refname}{Bibliographie}%
  }

will overcome this problem, but this solution is not stable - if the document later becomes a multi-language one, the original version of \refname will be restored every time the language switches back to French. The solution is to use the babel command \addto, as follows:

  \usepackage[frenchb]{babel}
  \addto{\captionsfrenchb}{%
    \renewcommand{\refname}{Bibliographie}%
  }

This last code will establish the new name for use at every change of to the language, and is the recommended way for defining new names. The \captionsfrenchb shown above is an example: in general the name to use is \captions<your language>, where \verb<your language> is the language option given to babel in the first place.


LaTeX2e (the `new' standard LaTeX)

LaTeX2e is the version of LaTeX prepared and supported by the LaTeX3 project team. With the advent of LaTeX2e, users gained a formal support structure, and the knowledge that bug fixes would be incorporated into the distribution on a fairly regular basis (new releases appear at approximately 6-month intervals).

LaTeX2e is so structured that significant enhancements may be added using macro add-ons, rather than by the different TeX formats that were the bane of the LaTeX 2.09 world.

LaTeX2e is upwardly compatible with LaTeX 2.09, but has new features. In the latest (June 1999) release, these include:

  • The font selection scheme is different (based on the `New Font Selection Scheme (NFSS) described by Frank Mittelbach and Rainer Schöpf in TUGboat 10(2). The NFSS the user may select a font by specifying an array of required properties (such as size, weight and series); commands that provide the LaTeX 2.09 syntax remain.

  • SliTeX is now merely a different document class, so that there is no longer a need for a separate format.
  • Better control of floating environments, such as figures.
  • There is a documented interface for package and class writers (though not yet for designers).
  • The box commands have been enhanced, with e.g., options to specify the height of a minipage.
  • Several standard commands are no longer fragile they can therefore be included in the argument of commands such as \caption without being protected.
  • \newcommand can define commands with one optional argument; such commands are automatically robust; there is also a separate command to define robust commands.
  • There are standard packages for graphics inclusion and colour typesetting.
  • There is standard support for typesetting in cyrillic.


The LaTeX3 project

The LaTeX3 project team (see http://www.latex-project.org/latex3.html) is a small group of volunteers whose aim is to produce a major new document processing system based on the principles pioneered by Leslie Lamport in the current LaTeX. It will remain freely available and it will be fully documented at all levels.

The LaTeX3 team's first product, LaTeX2e, was delivered in 1994, and the team undertakes its maintenance.


The Omega project

Omega is a program built as an extension of the TeX sources which works internally with 16-bit characters (Unicode); this allows it to work with most scripts in the world with much reduced coding scheme complications. Omega also has a powerful concept of input and output filters to allow the user to work with existing transliteration schemes, etc. Omega is an ongoing project by John Plaice (plaice@cse.unsw.edu.au) and Yannis Haralambous (\EmaildotYannis.Haralambous@univ-lille1.fr). An email discussion list is available: subscribe by sending a message `subscribe omega <your name>' to listserv@ens.fr

The base distribution of Omega was released in November 1996; it is available via systems/omega.tar.gz

Implementations of Omega are available as part of the teTeX, mikTeX, fpTeX and CMacTeX distributions (see the question on TeX systems).


The NTS project

The NTS project first saw the light of day at the Hamburg meeting of DANTE during 1992, as a response to an aspiration to produce something even better than TeX. The project is not simply enhancing TeX, for two reasons: first, that TeX itself has been frozen by Knuth (see the future of TeX), and second, even if they were allowed to develop the program, some members of the NTS team feel that TeX in its present form is simply unsuited to further development. While all those involved in the project are involved with, and committed to, TeX, they recognise that the end product may very well have little in common with TeX other than its philosophy.

Initially, and despite the reservations expressed at the inaugural meeting, the group is concentrating on extending TeX per se: members are implementing extensions and enhancements to TeX through the standard medium of a change-file. These extensions and enhancements, together with TeX proper, form a system called e-TeX, which is 100\ compatible with TeX; furthermore, it is possible during format creation to construct a format that is TeX: no extensions or enhancements are present.

The final aim of the project will be to produce an entirely new typesetting system, building on the experience gained in the earlier phases. This system is intended to provide a stable basis for typesetting in the future, in the way that TeX has since it was first offered to the world.

A distribution of e-TeX was made available in November 1996. It is available via systems/e-tex.tar.gz; e-TeX is also distributed on the TeX Live CDROM (see TeX CDROMs).


The PDFTeX project

PDFTeX (formerly known as TeX2PDF) arose from Han The Thanh's post-graduate research at Masaryk University, Brno, Czech Republic. The basic idea is very simple: to provide a version of TeX that can output PDF as an alternative format to DVI. PDFTeX implements a small number of new primitives, to switch to PDF output, and to control various PDF features. Han The Thanh is continuing work on the project; the latest version is available from systems/pdftex.tar.gz, and a version was distributed on the TeX Live CDROM (see TeX CDROMs).


What to do if you find a bug

For a start, make entirely sure you have found a bug. Double-check with books about TeX, LaTeX, or whatever you're using; compare what you're seeing against the other answers above; ask every possible person you know who has any TeX-related expertise. The reasons for all this caution are various.

If you've found a bug in TeX itself, you're a rare animal indeed. Don Knuth is so sure of the quality of his code that he offers real money prizes to finders of bugs; the cheques he writes are such rare items that they are seldom cashed. If you think you have found a genuine fault in TeX itself (or Metafont, or the CM fonts, or the TeXbook), don't immediately write to Knuth, however. He only looks at bugs once or twice a year, and even then only after they are agreed as bugs by a small vetting team. In the first instance, contact Barbara Beeton at the AMS (bnb@math.ams.org), or contact TUG.

If you've found a bug in LaTeX2e, look in the bugs database to see if it's already been reported. If not you should submit details of the bug to the LaTeX3 team. To do this, you should process the file latexbug.tex with LaTeX (the file is part of the LaTeX2e distribution. The process will give you instructions about what to do with your bug report (it can, for example, be sent to the team by email). Please be sparing of the team's time; they're doing work for the good of the whole LaTeX community, and any time they spend tracking down non-bugs is time not available to write or debug new code. Details of the whole process, and an interface to the database, are available via http://www.latex-project.org/help.html

If you've found a bug in LaTeX 2.09, or some other such unsupported software, there's not a lot you can do about it. You may find help or de facto support on a newsgroup such as comp.tex.tex or on a mailing list such as texhax@tex.ac.uk, but posting non-bugs to any of these forums can lay you open to ridicule! Otherwise you need to go out and find yourself a willing TeX-consultant - TUG maintains a register of TeX consultants (see http://www.tug.org/consultants.html).